This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] 64 Bit Dom0, Intel VT, cannot install Windows in DomU

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] 64 Bit Dom0, Intel VT, cannot install Windows in DomU
From: "Michael J. Baysek" <mjbaysek@xxxxxxxxxx>
Date: Thu, 21 Sep 2006 13:54:33 -0400
Delivery-date: Thu, 21 Sep 2006 10:55:17 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (X11/20060728)
I have been banging my head off the wall so long with this, that it is
about time to hire some drywall contractors.  Somebody Help!

I have tried everyone's suggestions so far and still had no success
installing Windows XP (32 bit) under my 64 bit dom0.

Quick Recap:

Dell Optiplex GX620 / x86_64 / Pentium D 940 with VMX / VT Enabled
(VMXON in xm dmesg)
FC5 Xen packages [.2187 xen0 kernel, and xen-3.0.2-3]
Tried all combinations of acpi, apic, and pae in domU config
Tried file: and tap:aio disk backends
Tried compiling xen 3.0.2 from xensource.com

Two outcomes I have experienced at different stages of this:
-The Windows XP install hangs at "Setup is starting Windows"
-The dom0 machine reboots instead of hanging at "Setup is starting Windows"

-I have tried the Press F5 to choose Standard PC as
but I only ever get the C-step i486 option and "Other".  No other
options are available.  I have tried this with a SP2 slipstreamed disc,
and an un-service-packed disk.

While not directly Xen related, below might be interesting to some of you:

Today I am trying to install XP with Qemu to run under Xen.  Still in
process of doing this, but something interesting I found.  When I try
the following:
qemu-system-x86_64 -kernel-kqemu -disk xp.disk -cdrom xp.iso -boot d -m 256

This was done with the kqemu module loaded under the 2178 release of
kernel-xen0 from FC5.

During this install, the machine reboots after or during Windows loading
of NTFS drivers (immediately preceding what would be next, which is
"Setup is starting Windows".

The install continues with the above command if I do not enable kqemu.

Does any of this information give anyone any hunches?  The wall in my
office thanks you in advance, and so do the drywall contractors.

-Mike B.

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>