This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Error: (22, 'Invalid argument')

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Error: (22, 'Invalid argument')
From: "Hesse, Christian" <mail@xxxxxxxxxxxx>
Date: Sun, 17 Sep 2006 14:04:53 +0200
Delivery-date: Sun, 17 Sep 2006 05:05:55 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <200609151340.49367.mail@xxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <200609151310.19128.mail@xxxxxxxxxxxx> <200609151340.49367.mail@xxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: KMail/1.9.4
On Friday 15 September 2006 13:40, Hesse, Christian wrote:
> On Friday 15 September 2006 13:10, Hesse, Christian wrote:
> > Hello everybody,
> >
> > I can successfully boot up my dom0, but I can't create domUs. If I try to
> > create one I get the following output from xm:
> >
> > root@revo:~# xm create /etc/xen/debian.cfg
> > Using config file "/etc/xen/debian.cfg".
> > Error: (22, 'Invalid argument')
> >
> > There's no more interesting information in syslog. Any ideas what is the
> > problem?
> Ok, here is the config file. /boot/bzImage is the kernel I used before
> playing with xen, so it's not a domU image, but the processor is a Core Duo
> T2300 that should have virtualization support.
> I tested with domU kernels as well, with the same result.

Ok, my fault was that I tried to boot a non-xen kernel with a non-hvm config. 
I could boot a Debian image with modified kernel and I managed to install 
Windows XP with a hvm config.
Actually my problem is that when I create the Windows domain the complete 
system freezes... I will take a deeper look at what could go wrong.

Attachment: pgpooQb8JHX2e.pgp
Description: PGP signature

Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>