This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Fwd: [Xen-users] Xen on MacBook Pro "Resolved (Partialy)"

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Fwd: [Xen-users] Xen on MacBook Pro "Resolved (Partialy)"
From: Andrej Javoršek <Andrej.Javorsek@xxxxxxxxxxxxx>
Date: Thu, 14 Sep 2006 13:07:53 +0200
Delivery-date: Thu, 14 Sep 2006 04:08:36 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <907625E08839C4409CE5768403633E0BA7FF08@xxxxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
It worked, but now I'm runing with 1/2 of processor   ;)


Begin forwarded message:

From: "Petersson, Mats" <Mats.Petersson@xxxxxxx>
Date: 14. september 2006 11:34:08 GMT+02:00
To: "Andrej Javoršek" <Andrej.Javorsek@xxxxxxxxxxxxx>
Subject: RE: [Xen-users] Xen on MacBook Pro

Try adding "nosmp" to the command line for Xen. That will run it on one core only, as it seems that there's a problem waking the second core. 

This is not a guarantee, but I read something like that on Xen-devel today.


-----Original Message-----
Andrej Javoršek
Sent: 14 September 2006 10:19
Subject: [Xen-users] Xen on MacBook Pro

I'm having problems booting xen dom0 on MacBook Pro.
I'm running Debian testing with kernels 2.6.16-2-686-smp,  
2.6.16-2-686 and with less success 2.6.17-2-xen-686 + 
Hypervisor from  
Other kernels work reasonably O.K. (except some Kernel panics... IO- 
APIC + timer not working during some reboots), but I'm only 
able to boot
Xen kernel in some 1 from 30 tries, otherwise computer 
restarts after  

[XEN] Scrubbing free RAM ...
[XEN] Xen trace buffers: disabled.....
.... the rest is unreadable because system restarts too fast...

If I succeed in booting Xen then system works o.k. I can start HVM  
domU (Linux, WinXP)....

I have tried also with original Xensource kernels and binaries, from  
3.0-testing, compiled from source from unstable, but all without  
have googled for hours but it seems that nobody had same problem.
Any suggestion very appreciated!!!

BTW: Apple HW test shows no fault, firmware seems to be the latest  

Andrej Javorsek

Xen-users mailing list

Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>
  • Fwd: [Xen-users] Xen on MacBook Pro "Resolved (Partialy)", Andrej Javoršek <=