This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Fail to install windows on Xen-3.0.2-2

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Fail to install windows on Xen-3.0.2-2
From: William Hanwoody <hanwoody@xxxxxxxxx>
Date: Sat, 9 Sep 2006 16:35:52 +0800
Delivery-date: Sat, 09 Sep 2006 01:36:57 -0700
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:from:organization:to:subject:date:user-agent:mime-version:content-type:content-transfer-encoding:content-disposition:message-id; b=pSjPhOI7kkUisLA4G8KJZ68euM7/8N8cNUswsffsRdvHInJ5JwheiSUWPT6Kv3bygR8vR795PN5wch4XMewIqbESzM1q7GGK7nH+NctcSLep+R9zclSL6vK2WFHW8FZC+hbyA2osLRvejamqRpuB9UyhSe0DF+oh+Z/a7UGb074=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Organization: Linux
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: KMail/1.9.3
My OS is the latest debian etch。
and I have installed needed packages:
bcc, bin86,libsdl1.2-dev,libsdl1.2debian, libsdl1.2debian-all, 
libvncserver-dev, python-dev。

I download xen-3.0.2-src.tgz from xensource, and compile it:
make KERNELS="linux-2.6-xen0" install

Because the default xen cannot support sata disk, so failed:
kernel panic: .....

and I custom 2.6.16-xen0, so I can boot xen-linux sucessfully.
of course I have enable vmx support in bios。
# xm info
host                   : han
release                : 2.6.16-xen0
version                : #1 SMP Sat Sep 9 11:37:58 CST 2006
machine                : i686
nr_cpus                : 2
nr_nodes               : 1
sockets_per_node       : 1
cores_per_socket       : 2
threads_per_core       : 1
cpu_mhz                : 1830
hw_caps                : bfe9fbff:00000000:00000000:00000140:0000c1a9
total_memory           : 1015
free_memory            : 407
xen_major              : 3
xen_minor              : 0
xen_extra              : .2-2
xen_caps               : xen-3.0-x86_32 hvm-3.0-x86_32
platform_params        : virt_start=0xfc000000
xen_changeset          : Thu Apr 13 15:18:37 2006 +0100 9617:5802713c159b
cc_compiler            : gcc version 3.3.6 (Debian 1:3.3.6-13)
cc_compile_by          : root
cc_compile_domain      : localdomain

I create a vmx configfile for windows2003: /etc/xen/win.vmx
import os, re
arch = os.uname()[4]
if re.search('64', arch):
    arch_libdir = 'lib64'
    arch_libdir = 'lib'
kernel = "/usr/lib/xen/boot/hvmloader"
memory = 300
name = "win"
vif = [ 'type=ioemu, bridge=xenbr0' ]
device_model = '/usr/' + arch_libdir + '/xen/bin/qemu-dm'
disk = [ 'file:/var/images/win2003..img,ioemu:hda,w' ]

and I run "xm create -c /etc/xen/win.hvm", but
SDL window cannot pop up. and log info in qemu-dm.log:
domid: 1
qemu: the number of cpus is 1
Connected to host network interface: tun0
shared page at pfn:16200, mfn: 23443
False I/O request ... in-service already: 0, pvalid: 0, port: 0, data: 0, 
count: 0, size: 0
HVM Loader
Loading ROMBIOS ...
Loading Cirrus VGABIOS ...
Loading VMXAssist ...
VMX go ...
VMXAssist (Aug 13 2006)
Start BIOS ...
Starting emulated 16-bit real-mode: ip=F000:FFF0
 rombios.c,v 1.138 2005/05/07 15:55:26 vruppert Exp $
HVM_PIT:guest init pit channel 0!
HVM_PIT:pass info 0xc00e90b to HV!
Remapping master: ICW2 0x8 -> 0x20
Booting from CD-Rom...
int13_harddisk: function 02, unmapped device for ELDL=80
int13_harddisk: function 08, unmapped device for ELDL=80
unsupported PCI BIOS function 0x0E
int13_harddisk: function 15, unmapped device for ELDL=80
int13_harddisk: function 08, unmapped device for ELDL=80
int13_harddisk: function 08, unmapped device for ELDL=80
int13_harddisk: function 08, unmapped device for ELDL=80
int13_harddisk: function 08, unmapped device for ELDL=80
HVM_PIT:guest init pit channel 0!
HVM_PIT:pass info 0xc002ead to HV!

Then I change win.hvm configfile:

but I get log info from qemu-dm.log:

domid: 2
qemu: the number of cpus is 1
/usr/lib/xen/bin/qemu-dm: invalid option -- '-vnc'

I have tried it for about two weeks, But both sdl and vnc failed。

is it a problem of xen, or a problem of debian packages?

Thanks for your help!

William Hanwoody                             hanwoody@xxxxxxxxx

A senior Linux engineer, like system integrate
My blog - hanwoody.livejournal.com
Obey all traffic laws.

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] Fail to install windows on Xen-3.0.2-2, William Hanwoody <=