This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Problem with network-bridge script and veth0

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Problem with network-bridge script and veth0
From: "Angel L. Mateo" <amateo@xxxxx>
Date: Tue, 05 Sep 2006 12:14:42 +0200
Delivery-date: Tue, 05 Sep 2006 03:15:46 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Organization: ATICA, Universidad de Murcia
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx

        Since my last update of xen, I am having problems with bridges and xen.
When I want to start a bridge on the dom0 (to run a domU in a different
vlan than the default) I run

/etc/xen/scripts/network-bridge start netdev=eth0.302 bridge=xen-br302

        where eth0.302 is an interface associated with my vlan 302 (it tags
with this vlan identifier).

        The problem I have is that it returns:

Link veth0 is missing.
This may be because you have reached the limit of the number of
interfaces that the loopback driver supports.  If the loopback driver is
a module, you may raise this limit by passing it as a parameter
(nloopbacks=<N>); if the driver is compiled statically into the kernel,
then you may set the parameter using loopback.nloopbacks=<N> on the
domain 0 kernel command line.

        I have checked the script and it fails because I don't have any veth0
interface. I have interfaces veth1 to veth7, but I don't have any veth0,
so if I run the same command with parameter vifnum=1 (for example) it
works, because it uses veth1 instead of veth0 and add it to the new
bridge (although it seems that this is not really necessary, because if
I remove veth? from the bridge, networking still works).

        My question is if not having veth0 is wrong or I can just simply ignore
this and use other vifnum than 0.

Angel L. Mateo Martínez
Sección de Telemática
Área de Tecnologías de la Información       _o)
y las Comunicaciones Aplicadas (ATICA)      / \\
http://www.um.es/atica                    _(___V
Tfo: 968367590
Fax: 968398337

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] Problem with network-bridge script and veth0, Angel L. Mateo <=