This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] NAT wont work in FC4

To: <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] NAT wont work in FC4
From: "Mito" <mito@xxxxxxxxxxxxx>
Date: Mon, 24 Apr 2006 16:07:55 -0400
Delivery-date: Mon, 24 Apr 2006 13:01:10 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcZn2sYTHFuj4DHbSVqf1Wtbo509XQ==

Ok, so I know that there has been a couple of questions asked recently about NAT in Xen, but even after going through those, I still can’t get this to work.


I’m still new to Xen, but I believe what I want to do should be easy, and I can’t figure it out.


The basis behind what I’m doing is as follows:  I am setting up a server to host several different things for me, each in it’s own domU, mailserver, webserver, etc.  Only problem is that I only have 1 static IP from my ISP available, so I need to share them all behind a NAT.  I plan on using my dom0 as a firewall/NAT for all my domU’s.


I originally setup my domU’s under the bridged mode just to get them up and running and make sure everything works.  It all worked well and I was able to access the internet perfectly.  So then I changed it over to the nat scripts that come with Xen and now I can’t get anything working.  I am using FC5 as my domU and my only domU right now is a FC4 system.  I have tried to use this link below even though it’s for debian, but I still can’t get it to work.




Obviously some of those paths (namely the ones for the network configuration files) are different between Debian and FC4, but those only come into play after the networking is actually working, when you want to setup the port forwarding.  I’m not even able to ping out to anywhere, even to the dom0.


On this system I installed Xen from the FC5 rpm’s (via yum).


I don’t get any errors, on any of the configurations, I just can’t get the domU to be able to ping anything.


Any help would be appreciated!




Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>