This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] crc checksum problems

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] crc checksum problems
From: Charles Mauch <cmauch@xxxxxxxxx>
Date: Tue, 3 Jan 2006 20:41:58 -0800
Delivery-date: Wed, 04 Jan 2006 04:59:01 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Mail-followup-to: xen-users@xxxxxxxxxxxxxxxxxxx
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt 1.5.11 (2005-09-15)
I've been struggling with a xen networking problem for more than a week now
and I ran out of ideas so I thought I'd ask for help here.  But first a bit
about my networt layout.

I have xen setup with a wrapper that establishes three bridges in xen,
which I named red, orange, and green.  eth0 is my public interface and is a
3com card, bound to the red bridge.  eth1 is my dmz interface, a forcedeth
(nvidia card), and it is bound to orange.  dummy0 is bound to green, and
all domU's on this bridge are in the network, including dom0.

I have a very small router/firewall domU that routes and filters all
traffic between these bridges.  It's a fun layout that works flawlessly in
xen 2.0.7.

When I upgrade to xen3, I experience tcp and udp checksum errors when
attempting to route any traffic through my firewall/router.  I tried to
enable "ethtool -K ethX tx off" in all of my domU's without success.  (When
I tried, the root user in each domU could access the rest of the network
fine, but not normal users ... and dom0 remained cut-off regardless of
superuser status.)

This behavior makes no sense to me whatsoever, and I was hoping someone
could point out some documentation or has an idea on how to proceed.  At
some point I'd like to upgrade :)

Oh, and I see the same behavior in the binary and custom-compiled kernels,
both the 3.0.0 release and the snapshot as of 2005-12-31.

Thanks ...

 - Charles

Attachment: pgpzSMiU6r94Y.pgp
Description: PGP signature

Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>