This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] PXE-booting Xen using PXELINUX

To: Tim Deegan <Tim.Deegan@xxxxxxxxxxxx>
Subject: Re: [Xen-users] PXE-booting Xen using PXELINUX
From: Yvette <yentlsoup@xxxxxxxxx>
Date: Thu, 5 May 2005 04:31:07 -0500
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Thu, 05 May 2005 09:30:43 +0000
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:message-id:date:from:reply-to:to:subject:cc:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=bhXTjJ3Cllo0dFypoQV6a5lbez+HbzHZl/T9raqsnwx5hDW71/G84fIywItfE1TIK2lQ9qmbjU09db/MOBxqm5Xd+9JxzxXT/boUoiwxqlXnsXkYYDrtkqqM0d6IzwycPjBHLnXDa2TCWWsscupWBtUwo5gAY86qR+awoYcA0p0=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20050428132954.GD12740@xxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <20050428132954.GD12740@xxxxxxxxxxxxxxxxx>
Reply-to: Yvette <yentlsoup@xxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Just saying "no" seems a bit severe, but I don't have a lot of other info. 

The client machine is an ibm thinkpad t22 (bios 1.12/current) with an
e100 (pro) nic. It's using version 4.0.17 of the Intel boot agent
(looks like it's the most recent they released for it). The dhcp/tftp
server is a domU running xen 2.0.5/debian sarge, with tftpd-hpa as the
server. I mainly tried your pxelinux.cfg/configuration from below,
although changing things around didn't change the outcome. After
booting and getting the ip address, it gets to this point, then hangs
at "Trying to load: pxelinux.cfg/default" or on the server side:

May  5 00:45:23 debian-domU in.tftpd[487]: RRQ from
filename pxelinux.0
May  5 00:45:23 debian-domU in.tftpd[488]: RRQ from
filename pxelinux.cfg/default
May  5 00:45:23 debian-domU in.tftpd[489]: RRQ from
filename mboot.c32

A tcpdump on the server pretty much just confirmed the logs - it
starts to transfer mboot.c32, carries on for a bit, then loses contact
with the client.

I tried to boot the same hardware/setup using the debian installer
(rc3) netboot pxe images, and those did work (which doesn't mean I
have it set up correctly for this - I'm about as far from being a PXE
guru as a person can get).

Sorry I couldn't be more helpful, but if you want me to try something
else, let me know.

On 4/28/05, Tim Deegan <Tim.Deegan@xxxxxxxxxxxx> wrote:
> Hi all,
> A number of people have posted to the Xen lists recently wanting to
> network-boot Xen on machines whose NICs are not supported by GRUB.  I've
> been writing a module for PXELINUX that will allow it to boot Xen
> directly over the network on PXE-enabled machines, without relying on
> any hacks (mbootpack, &c.), or needing to write/port any device drivers.
> I have a version of it which works for me [tm] and I'd be very
> interested in feedback from other people who want to PXE-boot Xen.
> Assuming you already have dhcp/tftp up and working at your site, it
> should be easy to test:
> 1) Edit dhcpd.conf to boot pxelinux on your Xen machine
>    (see http://syslinux.zytor.com/pxe.php ).
> 2) Download http://www.cl.cam.ac.uk/~tjd21/tmp/mboot.c32 and put it in your
>    tftpboot directory.
> 3) Copy xen, xenlinux and initrd into your tftpboot directory.
> 4) Edit the appropriate pxelinux.cfg file to contain a line invoking
>    mboot.c32, and then the xen and module command lines, separated by
>    '---'. For example, this one works for me:
>    DEFAULT mboot.c32 xen-2.0.5.gz dom0_mem=258048 --- vmlinuz-2.6.10-xen0 ro 
> console=tty root=/dev/hda --- initrd-2.6.10-xen0
> 3) Let me know if it works!  A simple yes/no would be great; details of
>    what hardware you're using and symptoms if it fails would be even
>    better.
> At some point in the next while I'll be submitting this code to the main
> SYSLINUX tree, with proper documentation and such-like bells and
> whistles.  In the meantime, feedback would be much appreciated.
> Cheers,
> Tim.
> --
> Tim Deegan                           (My opinions, not the University's)
> Systems Research Group
> University of Cambridge Computer Laboratory
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>