This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] xen 4.1.1 + 3.0.0-rc5 dom0 + blktap2

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] xen 4.1.1 + 3.0.0-rc5 dom0 + blktap2
From: Sébastien Riccio <sr@xxxxxxxxxxxxxxx>
Date: Wed, 29 Jun 2011 04:42:39 +0200
Delivery-date: Tue, 28 Jun 2011 19:43:21 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <1309314736.10719.1.camel@xxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <4E0A8907.6010300@xxxxxxxxxxxxxxx> <1309314736.10719.1.camel@xxxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20110620 Thunderbird/5.0b2
On 29.06.2011 04:32, Daniel Stodden wrote:
On Tue, 2011-06-28 at 22:08 -0400, Sébastien Riccio wrote:

I'm currently trying xen 4.1.1 with the 3.0.0-rc5 (heard that it now
contains the xen code to run as front or back xen domain).

Everything seems to run fine, except that I am trying since a  few hours
to mount a .vhd file in the dom0.

What I tried so far:

to create a blank vhd file (this is working):
host# vhd-util create -n /storage/test.vhd -s 20G

Then i try to mount the file in dom0 (as stated in a blktap2 README file)
host# tapdisk2 -n vhc:/storage/test.vhd
tap-ctl create -n vhd:/storage/test.vhd # :)

As a rule of thumb, there's no excuse to call tapdisk2 on the command
line. Should actually rather have gone into libexec.


Hi Daniel,

Thank you for your help. With this command I still get into the
"blktap kernel module not installed"

I'm using xen 4.1.1 compiled from source with a kernel 3.0.0-rc5 dom0 (compiled with all xen stuff enabled). Is there missing xen modules in the new kernel ? I try to use most recent xen enabled kernel. Is there a 2.3.29
xenfified kernel around ?

Thanks again,

Xen-devel mailing list