This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] Screen corruption and crash at boot with Xen 4.1.0 & linux 2

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] Screen corruption and crash at boot with Xen 4.1.0 & linux 2.6.39 on some systems
From: Anthony Wright <anthony@xxxxxxxxxxxxxxx>
Date: Thu, 2 Jun 2011 14:08:03 +0100 (BST)
Delivery-date: Thu, 02 Jun 2011 06:10:41 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <22045383.16.1307017943479.JavaMail.root@xxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
I have a custom built system based on LFS 6.6 with xen 4.1.0 & linux 2.6.39 
built from source. The system boots correctly on one system (after a problem 
with the USB disk has been worked around), however when I try to boot the same 
system on another machine the screen corrupts shortly after handover from the 
bootloader. This happens on 2 out of the 3 machines I have tried it on.

I was originally using xen 4.1.0 & linux, and with this combination 
the bootloader would work correctly, xen would work correctly and it would 
crash and the screen corrupt on the handover from xen to linux. I had a hunt 
around and found http://wiki.xensource.com/xenwiki/XenPVOPSDRM which talks 
about the graphics subsystem and says "What is boils down to is: if you want to 
use a stock kernel from ftp.kernel.org wait till 2.6.39 gets released". As a 
result I have switched to xen 4.1.0 & linux 2.6.39 but get the same result.

The motherboard is a Gigabit GA-MA69VM-S2.

The lspci -vvv output is attached.

What I did notice is the way the screen resolution changes during boot is 
different for the two main machines that I test on. On the machine that works, 
instead of the 80x25 console that I'm used to with xen 3.4.1, I get a much 
higher resolution output with two penguins at the top with 4.1.0. When I boot 
the system without the xen hypervisor linux starts at the 80x25 resolution but 
then quickly puts the screen into high resolution. On the machine that fails, 
when I boot the system without the xen hypervisor, linux starts at 80x25 
resolution, appears to do a resolution change (whole screen flickers) a few 
seconds later but leaves the resolution at 80x25.

Am I doing something wrong? Is this a bug? Is there a workaround? Should I try 
a different kernel version?

I'm happy to live with the 80x25 resolution screen but none of the screen 
resolution options that I've tried have had any effect.



Attachment: gs_ma69vm_s2-lspci-vvv
Description: Binary data

Xen-devel mailing list
<Prev in Thread] Current Thread [Next in Thread>