This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] PVOPS dom0 requires nomodeset to boot but video requires

To: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
Subject: Re: [Xen-devel] PVOPS dom0 requires nomodeset to boot but video requires modesetting driver
From: "John McDermott (U.S. Navy Employee)" <john.mcdermott@xxxxxxxxxxxx>
Date: Fri, 27 May 2011 11:31:01 -0400
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Fri, 27 May 2011 11:50:15 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20110527135545.GA6734@xxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <56912983-0699-4D79-8914-0805D9FA7DDA@xxxxxxxxxxxx> <20110527135545.GA6734@xxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx

Thanks. Domain 0 is one of Jeremy's pvops kernels, the latest, as far 
as I can tell, downloaded as a snapshot. The tarball called itself xen-51f9f52, 
but I don't know if that is a unique id. I am trying to bring this up on Fedora 
14. X forwarding works just fine. I have not set up the networking properly on 
this box, so that will not look right, but does not matter.

Attached are the outputs from the serial console, dmesg, lspci, and X logs for 
bare metal and Xen boots of the dom0 kernel:

Attachment: dumps.tgz
Description: Binary data



On May 27, 2011, at 9:55 AM, Konrad Rzeszutek Wilk wrote:

> On Fri, May 27, 2011 at 08:50:45AM -0400, John McDermott (U.S. Navy Employee) 
> wrote:
>> Xen Users,
>> In trying to bring up a new machine, I have debugged to the point that it 
>> appears that nomodeset is required to boot a pvops dom0 on Xen 4.0.1, on 
>> this machine (otherwise a udevd failure), but the video will not work 
>> without KMS, i.e. dom0 gets a "No modesetting driver detected" error. 
>> Everything in dom0 works fine remotely, including X forwarding, but no GUI 
>> on the console. I have tried all combinations of iommu, nomodeset, and 
>> nopat. I have also tried intel_iommu=igfx_off, without changing the results.
> You need to give more details. lspci -vv, dmesg, serial console, which 
> version of Dom0, etc.
>> Any suggestions?
> Couple, but not sure if they apply without the data above.

What is the formal meaning of the one-line program
#include "/dev/tty"

J.P. McDermott                  building 12
Code 5542                       mcdermott@xxxxxxxxxxxxxxxx
Naval Research Laboratory       voice: +1 202.404.8301
Washington, DC 20375, US        fax:   +1 202.404.7942

Xen-devel mailing list