This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] Fail to boot Xen raw image with hda converted from VMWARE vm

To: <xen-devel@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-devel] Fail to boot Xen raw image with hda converted from VMWARE vmdk image with scsi
From: <Lu.YJ@xxxxxxxxxxxx>
Date: Thu, 19 May 2011 15:45:21 +0800
Delivery-date: Thu, 19 May 2011 00:47:17 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: Acv1BQ6p8zapeRQUSH2JlZjCnlrLWAg6+Y4g
Thread-topic: [Xen-devel] Fail to boot Xen raw image with hda converted from VMWARE vmdk image with scsi

Hi everyone,


1.      I try to boot a raw image with hda under Xen hypervisor converted by VMWARE vmdk image with scsi, but fail to boot with error message “Error loading operating system” below”.

Who can give me a favor?


2.      Under vSphere,  create a windows XP VM with scsi storage then install a windows XP to the SCSI storage called xp.vmdk in the VM via iso file. Can successfully boot the VM under VMWARE hypervisor. Shutdown the VM.

3.      Use tool qemu-img to convert the vmware VM image xp.vmdk to raw image called xp.raw

4.      Create a XEN VM with hda to xp.raw. During booting the XEN VM, will appear the error message “Error loading operating system” below.



5.      I modify ide.c and rombios.c in xen hypervisor per the following link then rebuild hypervisor then replace “qemu-img and hvmload” with the built ones, but still fail to successfully boot with the same error message.



Note: My Xen platform is the CentOS5.5 64bit bundled with Xen 3.1.2.

Linux 2.6.18-194.8.1.el5xen #1 SMP Thu Feb 10 11:27:38 CST 2011 x86_64 x86_64 x86_64 GNU/Linux

xen_major              : 3

xen_minor              : 1

xen_extra              : .2-194.8.1.el5





Xen-devel mailing list
<Prev in Thread] Current Thread [Next in Thread>