This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Console is not working with Dom0 and Xen unstab

On Sat, Apr 30, 2011 at 07:17:54PM +0800, Wei Liu wrote:
> On Sat, Apr 30, 2011 at 6:41 PM, Pasi Kärkkäinen <pasik@xxxxxx> wrote:
> > So you're probably just missing a getty for hvc0 ?
> >
> I just tried. Login prompt shows up in serial console, but it doesn't
> react to my key strokes. VGA console has no login prompt.
> I tried two configs:
> /sbin/getty 115200 hvc0
> /sbin/getty -L 115200 hvc0 vt100
> If you have any working grub config, could you please share it with me?

An example that works for me:

title        pv_ops dom0 ( with serial console
root         (hd0,0)
kernel       /xen-4.0.gz dom0_mem=1024M loglvl=all guest_loglvl=all 
sync_console console_to_ring com1=57600,8n1 console=com1
module       /vmlinuz- ro root=/dev/vg00/lv01 console=hvc0 
earlyprintk=xen nomodeset
module       /initrd-

-- Pasi

Xen-devel mailing list