This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] BUG: unable to handle kernel paging request - balloon_init -

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] BUG: unable to handle kernel paging request - balloon_init - xen-4.1.0 -
From: Scott Garron <xen-devel@xxxxxxxxxxxxxxxxxx>
Date: Mon, 25 Apr 2011 20:04:20 -0400
Delivery-date: Mon, 25 Apr 2011 17:05:33 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20101226 Icedove/3.0.11
     It appears that a bug that I had reported back in August
) seems to have been fixed in a recent update (
) ... at least it looks like the same bug to me.  I've been trying, over
the past few days, to move to using a newer version with the fix applied
on a test machine and once I get it working, would like to update my
production server.  It would be nice to be able to get back to doing
backups again.  :)

     I don't know whether or not the fix for that bug worked, though,
because I can't seem to get any combination of a newer hypervisor and
Jeremy's xen.git xen/stable-2.6.32.x branch to boot at all.  I can get
the kernel to boot without Xen, but not with it.

     Here a snippet of serial output near the crash:

[    0.310132] xen_balloon: Initialising balloon driver with page order 0.
[    0.313482] last_pfn = 0x1d9ff0 max_arch_pfn = 0x400000000
[    0.316665] BUG: unable to handle kernel paging request at
[    0.316665] IP: [<ffffffff819a8aea>] balloon_init+0x20b/0x25e
[    0.316665] PGD c402067 PUD c403067 PMD 0
[    0.316665] Oops: 0002 [#1] SMP

Full serial output, lspci -vvv, .config, dmidecode, and grub2 conf can
be retrieved here:


git log:

commit 057b171345d94c785d7e8bb21302c5d1a23ea048
Merge: 6dfaa17 145fff1
Author: Jeremy Fitzhardinge <jeremy.fitzhardinge@xxxxxxxxxx>
Date:   Fri Apr 22 13:46:05 2011 -0700

git branch:
* xen/stable-2.6.32.x

hg log:
changeset:   23246:eb4505f8dd97
tag:         tip
user:        Tim Deegan <Tim.Deegan@xxxxxxxxxx>
date:        Wed Apr 20 12:02:51 2011 +0100
summary:     xen/x86: re-enable xsave by default now that it supports
live migration.

     I've tried booting with no dom0_mem option just to see if that made
any difference.  I also tried using the stable tarball of xen-4.1.0, the
current xen-4.1-testing.hg, as well as xen-unstable.hg.  All yield
exactly the same results.  Any ideas?

Scott Garron

Xen-devel mailing list