This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] Error connecting USB-device to DomU, kernel 2.6.32-5-xen-amd

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] Error connecting USB-device to DomU, kernel 2.6.32-5-xen-amd64, Xen 4.0.1
From: Hans van Zijst <hans@xxxxxxxxxxx>
Date: Tue, 01 Mar 2011 09:07:08 +0100
Delivery-date: Tue, 01 Mar 2011 00:08:06 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla-Thunderbird (X11/20100329)

When trying to connect my USB printer to the DomU that has CUPS
installed, I run into an error:

Unexpected error: <class 'xen.util.vusb_util.UsbDeviceParseError'>

Please report to xen-devel@xxxxxxxxxxxxxxxxxxx
Traceback (most recent call last):
  File "/usr/lib/xen-4.0/bin/xm", line 8, in <module>
  File "/usr/lib/xen-4.0/lib/python/xen/xm/main.py", line 3620, in main
    _, rc = _run_cmd(cmd, cmd_name, args)
  File "/usr/lib/xen-4.0/lib/python/xen/xm/main.py", line 3644, in _run_cmd
    return True, cmd(args)
  File "/usr/lib/xen-4.0/lib/python/xen/xm/main.py", line 2868, in
    if vusb_util.bus_is_assigned(bus):
  File "/usr/lib/xen-4.0/lib/python/xen/util/vusb_util.py", line 275, in
    raise UsbDeviceParseError("Can't get assignment status: (%s)." % bus)
xen.util.vusb_util.UsbDeviceParseError: vusb: Error parsing USB device
info: Can't get assignment status: (5-2).

I'm running Xen 4.0.1 on Debian Wheezy, kernel 2.6.32-5-xen-amd64, both
on Dom0 and the DomU.

I tried adding this line to the DomU's configuration:

vusb = [ 'usbver=2,numports=2,port_1=5-2,port_2=5-3' ]

which supposedly creates 2 USB ports on the DomU (I found a document on
the Internet describing PV-USB, but I can't find it anymore...). The
first port, 5-2, is the one to which the printer is connected.

After the DomU has booted, I issue "xm list-usb domu" on Dom0, which
gives me:

Idx BE  state usb-ver  BE-path
0   0   1     USB2.0  /local/domain/0/backend/vusb/14/0
port 1: 5-2 [ID 03f0:5511 HP Deskjet F300 series]
port 2: 5-3

So far, so good. The Dom0 seems to hand the printer to the DomU.
However, DomU doesn't seem to notice anything. When I do "lsusb" on it,
it bails out with:

unable to initialize libusb: -99

Manually loading the usbcore module and its friends doesn't help.

Now, if I explicitly connect this thing with:

xm usb-attach DomU 0 1 5-2

I get the error mentioned above.

Any ideas?

Kind regards,


Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>