This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Re: system freeze when processor.ko is loaded during boo

To: "Liu, Jinsong" <jinsong.liu@xxxxxxxxx>
Subject: Re: [Xen-devel] Re: system freeze when processor.ko is loaded during boot
From: Martin Wilck <mwilck@xxxxxxxx>
Date: Thu, 13 Jan 2011 22:29:56 +0100
Cc: "xen-devel@xxxxxxxxxxxxxxxxxxx" <xen-devel@xxxxxxxxxxxxxxxxxxx>, "Jiang, Yunhong" <yunhong.jiang@xxxxxxxxx>, "Dugger, Donald D" <donald.d.dugger@xxxxxxxxx>, Jan Beulich <JBeulich@xxxxxxxxxx>, "Li, Xin" <xin.li@xxxxxxxxx>, "Wei, Gang" <gang.wei@xxxxxxxxx>
Delivery-date: Thu, 13 Jan 2011 12:36:21 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <BC00F5384FCFC9499AF06F92E8B78A9E1E71175E22@xxxxxxxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Openpgp: id=70700BF2
References: <4CAF794F.6070308@xxxxxxxx> <4CBEAEE2020000780001E237@xxxxxxxxxxxxxxxxxx> <BC00F5384FCFC9499AF06F92E8B78A9E1E71175E22@xxxxxxxxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20100714 SUSE/3.0.6 Thunderbird/3.0.6
Dear Jinsong,

> I'd like to reproduce the bug at my desktop and have a look at it.
> I'm setting up debug environment now, and need some environment/config info 
> at your side:

I sent some Infos in November, but they may have got lost on their way
to the mailing list.

> 1. xen-upstable changeset
> 2. Jeremy pvops kernel version/ git commit/ .config file
xen/stable-2.6.32.x commit: 481bd8e6b8dafed2ea445e8cde2abbbb95b49ec1
config file attached
> 3. ioemu git commit

But I am certain none of these really matter a lot - I got the same
result with all kernels and hypervisors I tried so far since upgrading
to OpenSUSE 11.3. My previous xen hypervisor had no cpuidle or cpufreq

> 4. grub.conf file
title Xen4.1
    root (hd0,5)
    kernel /xen-4.1.gz vga=mode-0,keep cpufreq=xen cpuidle loglvl=all
    module /vmlinuz- root=/dev/mapper/vg-os11.2 vga=0 nomodeset
debug sysrq=9 S
    module /initrd-

> 5. processor.ko related config to load the modules at booting time (of Jeremy 
> pvops kernel, not SUSE)
I am not sure what you are referring to here. I have tried different
things. The usual SUSE way is to load processor.ko in the initrd
(INITRD_MODULES="ahci processor" in /etc/sysconfig/kernel).

> 6. xen/kernel booting serial log
I'd love to provide it, but I have no serial port. I am considering to
by a docking station to be able to get one.

> BTW, is xen still alive when dom0 kernel freeze? 
I don't think so.

> If yes, some dump log like key '0'/ 'c'/ 'd'/ 'q' is highly welcomed.
Please give me more hints - just hit '0' no Alt-sysrq or anything?

BTW, have you tried at some other platform beside Samsung XS50 laptop?
is it a machine specific issue?
> It could be. Noone else reported anything similar to SUSE. I only saw
it on this laptop.


Attachment: config.gz
Description: GNU Zip compressed data

Xen-devel mailing list