This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] issue moving guest from 3.2 to 4.01

To: chris <tknchris@xxxxxxxxx>
Subject: Re: [Xen-devel] issue moving guest from 3.2 to 4.01
From: Thomas Goirand <zigo@xxxxxxxxxx>
Date: Thu, 23 Dec 2010 13:37:27 +0800
Cc: Xen-Devel List <xen-devel@xxxxxxxxxxxxxxxxxxx>, Xen-Users List <xen-users@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Tue, 11 Jan 2011 02:36:06 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <AANLkTikMndOod2rk+xLf=FaonjsDT376DxHM=_Smqojq@xxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Organization: Debian
References: <AANLkTikMndOod2rk+xLf=FaonjsDT376DxHM=_Smqojq@xxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20101030 Icedove/3.0.10
On 12/23/2010 02:59 AM, chris wrote:
> Hello,
> I have a pv linux guest which works perfectly on 3.2 and when I moved
> the guest to the new server (debian squeeze, xen 4.0.1) I cannot start
> it, I get the following error:
> # xm create vm-customer.cfg
> Using config file "./vm-customer.cfg".
> Error: (1, 'Internal error', 'launch_vm: SETVCPUCONTEXT failed (rc=-1)\n')
> here is my domain config:
> http://pastebin.com/FEw9k9dr
> I assumed that it was due to the domU kernel not being compatible with
> the hypervisor so i replaced them with the domU kernel from squeeze
> but I still get the same error.
> A quick google returns a post about someone starting 100 domains and
> this occuring on the 101st domain, however in this case this is the
> first vm im putting on this machine so I don't think it is related.
> Has anyone had this issue? Any idea how I can debug this? I tried
> setting vcpus=1 and cpus=1 just to see if it wanted those directives
> but it doesnt seem to make any difference
Your VM is using sda1. Switch to the new device name system: xvda1.
Then you might have a chance to have it working... :)


Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • Re: [Xen-devel] issue moving guest from 3.2 to 4.01, Thomas Goirand <=