This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Using mini-os ioremap()

To: Samuel Thibault <samuel.thibault@xxxxxxxxxxxx>
Subject: Re: [Xen-devel] Using mini-os ioremap()
From: Matthew Fioravante <matthew.fioravante@xxxxxxxxxx>
Date: Thu, 06 Jan 2011 12:00:04 -0500
Cc: "xen-devel@xxxxxxxxxxxxxxxxxxx" <xen-devel@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Thu, 06 Jan 2011 09:02:03 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20110105225552.GI4618@xxxxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <4D24C587.6060907@xxxxxxxxxx> <20110105225552.GI4618@xxxxxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20100720 Lanikai/3.1.1
 My box doesn't have more than 4GB. I've tried this on 32 bit and 64 bit.

I tried nuking the mfn_is_ram check. When I do that the call returns a virtual memory address but when I try to read and write to it, it appears to act just like a normal page of memory and not the device.

Does anyone know offhand of a mini-os project that either tested the ioremap() call or actually does some memory mapped io operations?

On 01/05/2011 05:55 PM, Samuel Thibault wrote:
Matthew Fioravante, le Wed 05 Jan 2011 14:24:55 -0500, a écrit :
  I'm trying to map some mmio pages into my mini-os domain to use a
hardware device. The device is at address fed40000. I'm calling
ioremap() on this address but its failing, telling me that mfn fed40 is
in ram space. (Its failing the mfn_is_ram() check.)

What am I doing wrong here?
Mmm, I don't think anything you're doing is wrong. Notice the comment:

static long system_ram_end_mfn;
int mfn_is_ram(unsigned long mfn)
     /* very crude check if a given MFN is memory or not. Probably should
      * make this a little more sophisticated ;) */
     return (mfn<= system_ram_end_mfn) ? 1 : 0;

Do you have more than 4GiB memory, i.e. 0xfed40000 is actually between
two RAM areas?  In such case mfn_is_ram has to really get more

(In the interim you could just comment the mfn_is_ram() test from
do_ioremap to make things work)


Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

Xen-devel mailing list
<Prev in Thread] Current Thread [Next in Thread>