This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] testing dom0 on 2.6.37

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] testing dom0 on 2.6.37
From: M A Young <m.a.young@xxxxxxxxxxxx>
Date: Sun, 31 Oct 2010 19:35:39 +0000 (GMT)
Delivery-date: Sun, 31 Oct 2010 12:37:05 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Alpine 2.00 (LFD 1167 2008-08-23)
I built a kernel (currently at http://koji.fedoraproject.org/koji/taskinfo?taskID=2566143 ) based on 2.6.36-git13 with some Fedora patches but no additional xen patches. This kernel booted successfully as a dom0 (with xen-4.0.1). Next I tried booting a xen guest, using a kernel and initramfs which I thought might just work without needing the drivers that aren't in that kernel. It crashed with the following backtrace

BUG: unable to handle kernel paging request at ffff8800bdc6e698
IP: [<ffffffff810365a9>] ptep_set_access_flags+0x2b/0x51
PGD 1a04067 PUD 5ccf067 PMD 5ebe067 PTE 80100000bdc6e065
Oops: 0003 [#1] SMP
last sysfs file: /sys/devices/LNXSYSTM:00/device:00/PNP0C0A:00/power_supply/BAT0/charge_full
Modules linked in: ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat bridge stp llc rfcomm sco bnep l2cap xt_physdev ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables ipv6 evtchn xenfs uinput snd_hda_codec_idt snd_hda_codec_hdmi arc4 snd_hda_intel ecb snd_hda_codec snd_hwdep iwlagn iwlcore r852 sm_common snd_seq dell_laptop mac80211 nand microcode dell_wmi sparse_keymap nand_ids nand_ecc cfg80211 dcdbas sky2 snd_seq_device snd_pcm mtd btusb iTCO_wdt joydev bluetooth snd_timer rfkill wmi shpchp iTCO_vendor_support snd soundcore snd_page_alloc serio_raw i2c_i801 sdhci_pci sdhci firewire_ohci mmc_core firewire_core crc_itu_t i915 drm_kms_helper drm i2c_algo_bit i2c_core video output [last unloaded: scsi_wait_scan] Pid: 1746, comm: xend Not tainted 2.6.37-0.1.rc0.git13.xendom0.fc15.x86_64 #1 0U990C/Inspiron 1525 RIP: e030:[<ffffffff810365a9>] [<ffffffff810365a9>] ptep_set_access_flags+0x2b/0x51
RSP: e02b:ffff8800d0c43cd8  EFLAGS: 00010202
RAX: 8000000062c31701 RBX: ffff8800cfba2c00 RCX: 8000000062c31767
RDX: ffff8800bdc6e698 RSI: 00007f676dcd3000 RDI: ffff8800cfba2c00
RBP: ffff8800d0c43d08 R08: 0000000000000001 R09: 8000000062c31725
R10: 00007f676dcd3000 R11: 00007f67903b1c20 R12: 00007f676dcd3000
R13: 0000000000000001 R14: ffff8800d0fcf478 R15: ffff8800bdc6e698
FS: 00007f677d7fa710(0000) GS:ffff8800df07a000(0000) knlGS:0000000000000000
CS:  e033 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: ffff8800bdc6e698 CR3: 00000000ce8ec000 CR4: 0000000000002660
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process xend (pid: 1746, threadinfo ffff8800d0c42000, task ffff8800c07dc7c0)
 00007f676dcd3000 8000000062c31725 ffff8800bdc6e698 0000000000000000
 ffff8800cfba2c00 0000000000000000 ffff8800d0c43d98 ffffffff811038e9
 ffff8800d0c43d28 ffffffff8110531f ffff8800c069fb70 ffffffff8110021f
Call Trace:
 [<ffffffff811038e9>] do_wp_page+0x241/0x53d
 [<ffffffff8110531f>] ? handle_mm_fault+0x6e4/0x78e
 [<ffffffff8110021f>] ? pcpu_dump_alloc_info+0x111/0x229
 [<ffffffff81105355>] handle_mm_fault+0x71a/0x78e
 [<ffffffff8100744f>] ? xen_restore_fl_direct_end+0x0/0x1
 [<ffffffff810724af>] ? down_read_trylock+0x44/0x4e
 [<ffffffff814b2dca>] do_page_fault+0x363/0x385
 [<ffffffff8113118c>] ? fsnotify_modify+0x69/0x71
 [<ffffffff814aedae>] ? trace_hardirqs_off_thunk+0x3a/0x3c
 [<ffffffff814afe15>] page_fault+0x25/0x30
Code: 55 48 89 e5 41 55 41 54 53 48 83 ec 18 0f 1f 44 00 00 48 39 0a 48 89 fb 49 89 f4 0f 95 c0 45 85 c0 44 0f b6 e8 74 1c 84 c0 74 18 <48> 89 0a 48 8b 3f 0f 1f 80 00 00 00 00 4c 89 e6 48 89 df e8 a6
RIP  [<ffffffff810365a9>] ptep_set_access_flags+0x2b/0x51
 RSP <ffff8800d0c43cd8>
CR2: ffff8800bdc6e698

Is this expected or should it have worked?

        Michael Young

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>