This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] XFS causes Kernel trace with Jeremy's pv_ops kernel

To: Jeremy Fitzhardinge <jeremy@xxxxxxxx>
Subject: Re: [Xen-devel] XFS causes Kernel trace with Jeremy's pv_ops kernel
From: Ulf Kreutzberg <uk@xxxxxxxxxxxxx>
Date: Fri, 08 Oct 2010 12:15:53 +0200
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Fri, 08 Oct 2010 03:16:52 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4CAE413E.4050704@xxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <4CAD9D97.5070800@xxxxxxxxxxxxx> <4CAE413E.4050704@xxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); de; rv: Gecko/20100915 Lightning/1.0b2 Thunderbird/3.1.4
Hi Jeremy,

thank you for your answer.
I wonder if it is a then a problem with the git kernel.
It seems only to occur if it is running under Xen (4). If I boot the
kernel on bare metal, anythig works fine. As an additional info, under
kernel (formerly taken from git) under xen 3.4.0 (which is then
not a pv_ops kernel) all works fine, too.
So my question would be, how to get the issue solved? Do you have any Ideas?

Best regards,

Am 07.10.2010 23:53, schrieb Jeremy Fitzhardinge:
>  On 10/07/2010 03:14 AM, Ulf Kreutzberg wrote:
>> Hi Jeremy,
>> hi all,
>> I have checked out Jeremy's last git built of dom0 pv_ops kernel
>> commit 41a85de5caef68bbd58e11ed7b781b7867d96eaa
>> Merge: 62bf426... 0ee0f94...
>> Author: Jeremy Fitzhardinge <jeremy.fitzhardinge@xxxxxxxxxx>
>> Date:   Tue Sep 28 11:20:40 2010 -0700
>> I have set up on a Dell PE1950 2xDualXeon 5130 an LVM2 partition
>> containing XFS. I have built Jeremy's kernel successfully, so the
>> running dom0 Kernel is the one mentioned above.
>> System is Debian-Lenny, Xen and Xen-tools are self-built.
>> If I make some I/O, eg:
>> cd linux-2.6-xen-git (which is then on the lv with the XFS filesystem)
>> make -j 7 ; make install; make -j 7 modules; make modules_install
>> in dmesg appears a kernel trace after a while. But compiling continues
>> and all keeps up and running. This only happens if the kernel is running
>> under xen 4.0.2-rc1-pre hypervisor. Nothing strange happens if I run it
>> on bare-metal (same machine) without hypervisor.
>> I have not tested bonnie or iozone yet.
>> I have attached booting output of xen 4.0.2-rc1-pre
>> as well as the trace (file console-kerneltrace.txt).
>> Kernel config is also attached (config-
> This doesn't look obviously Xen specific.  At least at one point XFS was
> prone to spurious lockdep warnings that were hard to eliminate.  I
> wonder if its possible you're seeing this under Xen because of some kind
> of timing issue?
> Of course it could be Xen related too, but as I said, nothing stands out.
>     J
>> Perhaps you can help. Please let me know if I have forgotten any
>> important information.
>> Many thanks and best regards,
>> Ulf Kreutzberg
>> Viele Grüße,
>> Ulf
>> _______________________________________________
>> Xen-devel mailing list
>> Xen-devel@xxxxxxxxxxxxxxxxxxx
>> http://lists.xensource.com/xen-devel

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>