This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Error expanding grant table frames

To: "Phil Winterfield (winterfi)" <winterfi@xxxxxxxxx>, "xen-devel@xxxxxxxxxxxxxxxxxxx" <xen-devel@xxxxxxxxxxxxxxxxxxx>
Subject: Re: [Xen-devel] Error expanding grant table frames
From: Keir Fraser <keir.fraser@xxxxxxxxxxxxx>
Date: Fri, 27 Aug 2010 08:48:57 +0100
Delivery-date: Fri, 27 Aug 2010 00:49:57 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <38AD81989214D54EB5F20C69477AF6C10C39B1B6@xxxxxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: ActFe8bMRHHGEv7ITXOLQPWI8jEDDAAQIbm/
Thread-topic: [Xen-devel] Error expanding grant table frames
User-agent: Microsoft-Entourage/
On 27/08/2010 01:07, "Phil Winterfield (winterfi)" <winterfi@xxxxxxxxx>

> When I start up a 32-bit PV guest with a pair of passthrough NIC ports, I am
> seeing the following error:
> (XEN) grant_table.c:1121:d1 Expanding dom (1) grant table from (4) to (16)
> frames.
> (XEN) mm.c:883:d1 Error getting mfn 212ef (pfn 1d210) from L1 entry
> 00000000212ef023 for l1e_owner=1, pg_owner=1

Domain 1 presented a pagetable entry mapping a page that either it does not
own, or is unable to map with write permissions (e.g., because it is already
a pagetable page and permitting write mappings would be unsafe).

> (XEN) grant_table.c:266:d0 Bad flags (0) or dom (0). (expected dom 0)

Dom0 tried to map a page via a grant reference passed to it by another
domain (probably dom1). When Xen checked the permissions in dom1's grant
table, it found all zeroes, which is invalid. This is probably related to
the above page-table error: perhaps the failed mapping is of dom1's extended
grant table and hence it failed to write grant details into the grant table.
That's the angle I would investigate with further tracing in Xen and in
dom0's grant-table code.

 -- Keir

> I am running the 64-bit linux- pvops kernel for dom0 along with
> xen-unstable c/s 22068.  This problem has been around for quite a long time
> and was fixed in the OpenSuse11.1 release which had the linux-2.6.27 kernel
> for dom0 paired with xen-3.4.  In all of the subsequent releases that I have
> tried, the problem has returned.  A few searches have shown that the problem
> has been observed by others, usually when running 32-bit guests with
> passthrough NICs.  In some instances the error was observed when dom0 was
> mapping shared RX ring buffers.
> Any ideas as to where something like this might be originating?

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>