This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Tapdisk2 problem

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] Tapdisk2 problem
From: Luís Silva <luis.silva@xxxxxxxxxxxxx>
Date: Sun, 15 Aug 2010 17:14:01 +0100
Cc: Jeremy Fitzhardinge <jeremy@xxxxxxxx>
Delivery-date: Sun, 15 Aug 2010 09:15:03 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <1280930679.3277.11.camel@luis-port>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Organization: Axiomasoft
References: <1280930679.3277.11.camel@luis-port>
Reply-to: luis.silva@xxxxxxxxxxxxx
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Hello again,

I've tried updating the kernel as blktap has had some work on it, but the problem remains. The up to date xen/stable-2.6.32.x still behaves as described bellow. Also, I've tested this procedure against kernel with Suse backported patches and the problem doesn't exist. I haven't still tried updating xen to 4.0.1-rc6, but from the changelog I don't see anything that could change this behaviour...

Is anyone with an up to date xen/stable-2.6.32.x kernel seeing this problem or is it just I?


On Wed, 2010-08-04 at 15:04 +0100, Luís Silva wrote:

I'm using both xen 4.0.1-rc5 and the latest pv_ops dom0 kernel (branch xen/stable-2.6.32.x), but I'm having some problems with tapdisk2...

Basically, if I create a tap device (tapdisk2 -n aio:/var/lib/libvirt/images/srv-001-ub1004.img), when I try to terminate it by issuing "echo 1 > /sys/class/blktap2/blktap0/remove", the last command hangs and tapdisk2 hangs using 100% cpu.

This happens both on manual device destruction and on virtual machine shutdown. I don't know exactly what triggered this behaviour, but I suspect kernel changes.

Can anyone confirm this behaviour?

Xen-devel mailing list

Attachment: signature.asc
Description: This is a digitally signed message part

Xen-devel mailing list