This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] [PATCH 0/2] Fix could not boot vm image which converted

To: Ian Jackson <Ian.Jackson@xxxxxxxxxxxxx>
Subject: Re: [Xen-devel] [PATCH 0/2] Fix could not boot vm image which converted from phy-partition
From: Joe Jin <joe.jin@xxxxxxxxxx>
Date: Wed, 11 Aug 2010 16:00:57 +0800
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx, haobo.zhou@xxxxxxxxxx, Joe Jin <joe.jin@xxxxxxxxxx>, greg.marsden@xxxxxxxxxx, Keir Fraser <keir.fraser@xxxxxxxxxxxxx>
Delivery-date: Wed, 11 Aug 2010 01:04:01 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <19553.30047.76482.165901@xxxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <20100805233516.GB21473@xxxxxxxxxxxxxxxxxxxxxxx> <19553.30047.76482.165901@xxxxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/
On 2010-08-10 16:50, Ian Jackson wrote:
> Joe Jin writes ("[Xen-devel] [PATCH 0/2] Fix could not boot vm image which 
> converted from phy-partition"):
> > When booting up windows VM which converted by dd windows physical
> > partition, it failed with "Error Loading Operating System", the
> > partition build on scsi/raid controller. The root cause is qemu
> > and hvmloader could not calaulated C/H/S correctly, then ntloader
> > could not found the root partition.
> Thanks for this, but I'm afraid I'm kind of missing the background
> here.  I'm not very familiar with how the CHS-guessing works.  Perhaps
> you could explain ?

The background is we dd physical MS-Windows partition, physical disk based
on RAID controller, we tried to boot it but failed with "Error Loading
Operation System".

The error message reported by rombios for it could not find the first
sector. qemu calculated CHS by read MBR(the first 512 bytes) of image file,
when H(eads)>16, qemu set it to default value heads(16). in fact disk on 
RAID heads is 32, this made qemu pass incorrect offset of image file to 
rombios, then rombios failed to find the boot loader.

> Also, have you looked at upstream qemu to see what is done there ?
> We're currently working on a merge of qemu-dm back into upstream qemu
> and if possible we'd like to avoid adding more interface
> incompatibilities.

I did not check qemu codes but we have tried to boot up the image file
by qemu, same error, we did not applied the patch to qemu.


Xen-devel mailing list