This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] HVM hypercalls

To: Ruslan Nikolaev <nruslan_devel@xxxxxxxxx>
Subject: Re: [Xen-devel] HVM hypercalls
From: Stefano Stabellini <stefano.stabellini@xxxxxxxxxxxxx>
Date: Mon, 9 Aug 2010 10:41:10 +0100
Cc: "xen-devel@xxxxxxxxxxxxxxxxxxx" <xen-devel@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Mon, 09 Aug 2010 02:41:43 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <363004.42397.qm@xxxxxxxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <363004.42397.qm@xxxxxxxxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Alpine 2.00 (DEB 1167 2008-08-23)
On Fri, 6 Aug 2010, Ruslan Nikolaev wrote:
> I tried these configs. The same result - it does not find root device.
> However, if I disable 'CONFIG_XEN_PLATFORM_PCI', everything works. I can see 
> my disk as /dev/sda.
> If CONFIG_XEN_PLATFORM_PCI is enabled (by default), virtual ATA device 
> appears, I can see GRUB, load the kernel. But when kernel tries to mount root 
> device, it cannot find it. There is no /dev/xvda*, no /dev/hda*, no 
> /dev/sda*, nothing! Apparently, it's a problem with actual kernel disk driver 
> (not configuration). I get the same result also if I specify physical device.
> Also, I noted weird messages in dom0:
> XENBUS: Unable to read cpu state

The disk might appear with a name starting with xvd but different from
xvda. Do you have any xvd devices at all?

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>