This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Problems with xen and linux 2.26.32 kernels for dom0

To: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
Subject: Re: [Xen-devel] Problems with xen and linux 2.26.32 kernels for dom0
From: Jia Rao <rickenrao@xxxxxxxxx>
Date: Fri, 18 Jun 2010 11:24:41 -0400
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Fri, 18 Jun 2010 08:25:26 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:received:in-reply-to :references:date:message-id:subject:from:to:cc:content-type; bh=bHI5bXLurnoKxtLdsZJhRFmi4Yb7Le/HTTMaNoERDac=; b=A94Qt0Y+oquT0xnXIx8PrX35CuSpWGq4VU0JL/qD7TnCKBSsYhMvU8gZwqeHWTvGkP Z0P81tBvQkFk8H15Hg0lFadPOIwWluvyMb0kKw9cIlZsITXApvVFEoFU8OKPxhKpzas6 8dnRSoGBlmsHp4BO4101/R2t4HiOi/rFXCZSM=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type; b=U66fLNcBH1Dxsg4QWSAHeaEXw6FHpivb/bOGxU+j7+TRTaLaAqvWR3z83Dae6Xfea5 uGp6+AOcNzXQjsEfoHmgdf+J1MZQ6rUsTOHEmuIp8X2LdH5/2m0Au3UFQ1PDPzCBwAN0 ik0g8VspQ/5I1ehs+pNeOx6HUnMDriGxtFFCg=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20100617130857.GA3474@xxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <AANLkTilUPKPuECSWT_ySDkKfdLs5OPwlzFnW5Op6_SSd@xxxxxxxxxxxxxx> <20100616194310.GB8413@xxxxxxxxxxxxxxxxxxx> <AANLkTikquVOOExVhUpUQo4TNMe6IWSZXMGT1E4jOkIXh@xxxxxxxxxxxxxx> <20100617130857.GA3474@xxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Finally the 2.6.32 pvops dom0 booted with xen 4.0. However the xend can not start.
I believe that is something related to the evtchn.
I compile the CONFIG_XEN_DEV_EVTCHN=y in kernel, so i donot need to load it. When the dom0 booted, I can see there is a entry for evtchn in /dev/xen along with gntdev.

But when xend starts, the evtchn in /dev/xen disappeared. and xend is not properly started.
The error log in /var/log/xen/xend.log is the following:

[2010-06-18 10:51:35 4685] INFO (SrvDaemon:332) Xend Daemon started
[2010-06-18 10:51:35 4685] INFO (SrvDaemon:336) Xend changeset: unavailable.
[2010-06-18 10:51:35 4685] ERROR (SrvDaemon:349) Exception starting xend ((111, 'Connection refused'))

I am using a centos 5, which has an old udev. I tried to modified the udev rules in /etc/udev/rules.d/xen-backend.rules and changed evtchn to xen-evtchn. No luck.

Any ideas?


On Thu, Jun 17, 2010 at 9:08 AM, Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx> wrote:
> > > generated initrd, dom0 can not boot. I got the error: *unable to locate
> > > IOAPIC for GSIx and mount: could not find filesystem: /dev/root*.
> > > tried to use root=/dev/sdax or root=LABEL=/. No luck.
> >
> > You did follow the the Wiki:
> > http://wiki.xensource.com/xenwiki/2.6.18-to-2.6.31-and-higher
> >
> > and made sure you had the right SATA drivers compiled in? They changed
> > their names from .18 to .31-and-higher
> > >
> >
> I tried the script with the pvops, the dom0 still cannt boot. How can I
> check if other modules have changed the name besides ata_piix ?

find /sys/class/scsi_host/host*/proc_name | xargs cat

If the name of the module exists in 2.6.32, OK, otherwise use Google.

You did also use the 'new-kernel-package' to insert your new kernel
and/or ran 'mkinitrd' (pre FC12) or 'dracut' (past FC12).

Xen-devel mailing list