WARNING - OLD ARCHIVES

This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
   
 
 
Xen 
 
Home Products Support Community News
 
   
 

xen-devel

RE: [Xen-devel] failed to build xen from source code

Hi
 
I forgot something to modify,and xen works now and there are still some problems.
 
The following is the message when booting
  mount: xenfs already mounted or /proc/xen busy
  mount: according to mtab, none is already mounted on /proc/xen
If I remove the  "none /proc/xen xenfs defaults 0 0" in /etc/fstab,there is not this message but xen can't work,too
Is this message correct or I have to modify something ?


The second problem is booting takes a long time.
After showing the message above,it takes about 2 minutes or more then entering OS.
I find some error messages in /log/messages

May 31 15:16:02 localhost kernel: XENBUS: Unable to read cpu state
May 31 15:16:02 localhost kernel: XENBUS: Unable to read cpu state
May 31 15:16:02 localhost kernel: XENBUS: Unable to read cpu state
May 31 15:16:02 localhost kernel: XENBUS: Unable to read cpu state
May 31 15:16:02 localhost kernel: XENBUS: Unable to read cpu state
May 31 15:16:02 localhost kernel: xenbus_probe_devices backend
May 31 15:16:02 localhost kernel: xenbus_probe_devices failed xenbus_directory
May 31 15:16:02 localhost kernel: backend_probe_and_watch devices probed ok
May 31 15:16:02 localhost kernel: backend_probe_and_watch watch add ok ok
May 31 15:16:02 localhost kernel: backend_probe_and_watch all done
May 31 15:16:02 localhost kernel: xenbus_probe_devices device
May 31 15:16:02 localhost kernel: xenbus_probe_devices failed xenbus_directory
May 31 15:16:02 localhost kernel: frontend_probe_and_watch devices probed ok
May 31 15:16:02 localhost kernel: frontend_probe_and_watch watch add ok ok
May 31 15:16:02 localhost kernel: frontend_probe_and_watch all done
The problem is caused by these error?
 
Thanks

From: Pasi Kärkkäinen [mailto:pasik@xxxxxx]
Sent: 2010/5/31 [星期一] 下午 12:57
To: Wen Che Chang (RD-TW)
Cc: Xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] failed to build xen from source code

On Mon, May 31, 2010 at 10:38:32AM +0800, wenche_chang@xxxxxxxxxxxx wrote:
>    Hi pasi
>
>    After following the fstab entry on the XenParavirtOps wiki page,there are
>    files in /proc/xen
>    I also check the dom0 config file, and there is "<*> Xen /dev/xen/evtchn
>    device".
>    But in lsmod,there is not xen-evtchn.
>    I tried modprobe xen-evtchn,and it shows "FATAL : xen_evtchn not found"
>    do I forget something to do??
>

You have compiled it statically in, so then it's not built as a module.
No need to load it, it's already in there.

After you see files under /proc/xen you should be able to start xend.

If it still doesn't work.. do you have selinux enabled?

-- Pasi

>    thanks
>
>    --------------------------------------------------------------------------
>
>    From: Pasi Kärkkäinen [mailto:pasik@xxxxxx]
>    Sent: 2010/5/28 [¬PŽÁ塴 嗹È 06:27
>    To: Wen Che Chang (RD-TW)
>    Cc: Xen-devel@xxxxxxxxxxxxxxxxxxx
>    Subject: Re: [Xen-devel] failed to build xen from source code
>
>    On Fri, May 28, 2010 at 06:18:18PM +0800, wenche_chang@xxxxxxxxxxxx wrote:
>    > Hi pasi
>    >
>    > You are right.
>    > There is not any file in /proc/xen and I can't see xen-evtchn when I run
>    lsmod.
>    >
>    > But I don???t know how to fix these problems even I read the link in
>    wiki.
>    > Can you provide more detail reference?
>    >
>
>    - Check your dom0 kernel .config file. Is the Xen event channel compiled
>    in, or is it built as a module?
>      If it's a module, then use "modprobe xen-evtchn" to load it.
>
>    - For mounting /proc/xen see the example fstab entry on the XenParavirtOps
>    wiki page. Add the line to /etc/fstab and after that run "mount
>    /proc/xen".
>      Xen 3.4.3 and 4.0.0 should automatically mount /proc/xen though.
>
>    -- Pasi
>
>    > thanks a lot.
>    > -----Original Message-----
>    > From: Pasi Kärkkäinen [[1]mailto:pasik@xxxxxx]
>    > Sent: Friday, May 28, 2010 5:48 PM
>    > To: Wen Che Chang (RD-TW)
>    > Cc: Xen-devel@xxxxxxxxxxxxxxxxxxx
>    > Subject: Re: [Xen-devel] failed to build xen from source code
>    >
>    > On Fri, May 28, 2010 at 05:35:09PM +0800, wenche_chang@xxxxxxxxxxxx
>    wrote:
>    > > Hi
>    > > I have read  "Xend does not start when using pv_ops dom0 kernel? "in
>    this link and I don???t think it's my problem
>    > >
>    > > I download SRPM of XEN 4.0.0 from
>    [2]http://pasik.reaktio.net/fedora/xen-4.0.0-0.7.fc12.src.rpm or
>    [3]http://fedorapeople.org/~myoung/dom0/src/xen-4.0.0-0.7.fc12.src.rpm
>    > >
>    > > After installation it in Fedora 12 , xend works well, but it can't
>    start if I install Xen from [4]http://xenbits.xen.org/xen-4.0-testing.hg
>    > >
>    >
>    > I think the init scripts in Fedora rpm do more than the default scripts
>    in upstream Xen.
>    >
>    > So:
>    >       - Do you have /proc/xen (xenfs) mounted? Do you have files in it?
>    >       - Do you have xen-evtchn driver loaded? Run lsmod if it's compiled
>    as a module in your dom0 kernel.
>    >
>    > Both of those need to be OK before xend starts.
>    >
>    > -- Pasi
>    >
>    > > -----Original Message-----
>    > > From: Pasi Kärkkäinen [[5]mailto:pasik@xxxxxx]
>    > > Sent: Friday, May 28, 2010 4:51 PM
>    > > To: Wen Che Chang (RD-TW)
>    > > Cc: jeremy@xxxxxxxx; Xen-devel@xxxxxxxxxxxxxxxxxxx
>    > > Subject: Re: [Xen-devel] failed to build xen from source code
>    > >
>    > > On Fri, May 28, 2010 at 03:33:54PM +0800, wenche_chang@xxxxxxxxxxxx
>    wrote:
>    > > >    Hi
>    > > >
>    > > >    after install these two RPMs , I can build and install the xen
>    4.0.1
>    > > >
>    > > >    But there are some troubles about xend , the error message is
>    shown as
>    > > >    below
>    > > >
>    > > >    [root@localhost ~]# xm list
>    > > >     Unable to connect to xend: No such file or directory. Is xend
>    running?
>    > > >
>    > > >    [root@localhost ~]# xend
>    > > >    ERROR Internal error: Could not obtain handle on privileged
>    command
>    > > >    interface (2 = No such file or directory)
>    > > >    Traceback (most recent call last):
>    > > >      File "/usr/sbin/xend", line 36, in <module>
>    > > >        from xen.xend.server import SrvDaemon
>    > > >      File
>    "/usr/lib64/python2.6/site-packages/xen/xend/server/SrvDaemon.py",
>    > > >    line 26, in <module>
>    > > >        import relocate
>    > > >      File
>    "/usr/lib64/python2.6/site-packages/xen/xend/server/relocate.py",
>    > > >    line 28, in <module>
>    > > >        from xen.xend import XendDomain
>    > > >      File
>    "/usr/lib64/python2.6/site-packages/xen/xend/XendDomain.py", line
>    > > >    36, in <module>
>    > > >        from xen.xend import XendOptions, XendCheckpoint,
>    XendDomainInfo
>    > > >      File
>    "/usr/lib64/python2.6/site-packages/xen/xend/XendCheckpoint.py",
>    > > >    line 20, in <module>
>    > > >        from xen.xend import balloon, sxp, image
>    > > >      File "/usr/lib64/python2.6/site-packages/xen/xend/image.py",
>    line 46, in
>    > > >    <module>
>    > > >        xc = xen.lowlevel.xc.xc()
>    > > >    xen.lowlevel.xc.Error: (1, 'Internal error', 'Could not obtain
>    handle on
>    > > >    privileged command interface (2 = No such file or directory)')
>    > > >
>    > > >
>    > > >    Any idea?
>    > > >
>    > >
>    > >
>    > > Try reading the troubleshooting tips at:
>    > > [6]http://wiki.xensource.com/xenwiki/XenParavirtOps
>    > >
>    > >
>    > > -- Pasi
>    > >
>    > >
>    > > >
>    --------------------------------------------------------------------------
>    > > >
>    > > >    From: Jeremy Fitzhardinge [[7]mailto:jeremy@xxxxxxxx]
>    > > >    Sent: 2010/5/28 [¬PŽÁ£á] £áU£áÈ 12:19
>    > > >    To: Wen Che Chang (RD-TW)
>    > > >    Cc: Xen-devel@xxxxxxxxxxxxxxxxxxx
>    > > >    Subject: Re: [Xen-devel] failed to build xen from source code
>    > > >
>    > > >    On 05/27/2010 08:47 PM, wenche_chang@xxxxxxxxxxxx wrote:
>    > > >    > Hi
>    > > >    > I tried to install Xen 4.0.1 from
>    > > >    > [1][8]http://*xen*bits.*xen*.org/*xen*-*4.0*-testing.hg
>    > > >    > <[2][9]http://xenbits.xen.org/xen-4.0-testing.hg>
>    > > >    > I use the installation step in Xen wiki as shown below
>    > > >    > yum groupinstall "Development Libraries"
>    > > >    > yum groupinstall "Development Tools"
>    > > >    > yum install transfig texi2html libaio-devel dev86 glibc-devel
>    > > >    e2fsprogs-devel gitk mkinitrd iasl xz-devel bzip2-devel
>    > > >    > hg clone [3][10]http://xenbits.xen.org/xen-4.0-testing.hg
>    > > >    > cd xen-4.0-testing.hg
>    > > >    > make xen
>    > > >    > make tools
>    > > >    > make stubdom
>    > > >    > I failed in  "make tools" and it shows
>    > > >    > /usr/bin/ld: cannot find -lpci
>    > > >    >
>    > > >
>    > > >    I think you also need pciutils-libs and pciutils-devel.
>    > > >
>    > > >    J
>    > > >
>    > > > TREND MICRO EMAIL NOTICE
>    > > > The information contained in this email and any attachments is
>    confidential and may be subject to copyright or other intellectual
>    property protection. If you are not the intended recipient, you are not
>    authorized to use or disclose this information, and we request that you
>    notify us by reply mail or telephone and delete the original message from
>    your mail system.
>    > > >
>    > > > References
>    > > >
>    > > >    Visible links
>    > > >    1. [11]http://*xen*bits.*xen*.org/*xen*-*4.0*-testing.hg
>    > > >    2. [12]http://xenbits.xen.org/xen-4.0-testing.hg
>    > > >    3. [13]http://xenbits.xen.org/xen-4.0-testing.hg
>    > >
>    > > > _______________________________________________
>    > > > Xen-devel mailing list
>    > > > Xen-devel@xxxxxxxxxxxxxxxxxxx
>    > > > [14]http://lists.xensource.com/xen-devel
>    > >
>    > >
>    > > TREND MICRO EMAIL NOTICE
>    > > The information contained in this email and any attachments is
>    confidential and may be subject to copyright or other intellectual
>    property protection. If you are not the intended recipient, you are not
>    authorized to use or disclose this information, and we request that you
>    notify us by reply mail or telephone and delete the original message from
>    your mail system.
>    >
>    > TREND MICRO EMAIL NOTICE
>    > The information contained in this email and any attachments is
>    confidential and may be subject to copyright or other intellectual
>    property protection. If you are not the intended recipient, you are not
>    authorized to use or disclose this information, and we request that you
>    notify us by reply mail or telephone and delete the original message from
>    your mail system.
>
> TREND MICRO EMAIL NOTICE
> The information contained in this email and any attachments is confidential and may be subject to copyright or other intellectual property protection. If you are not the intended recipient, you are not authorized to use or disclose this information, and we request that you notify us by reply mail or telephone and delete the original message from your mail system.
>
> References
>
>    Visible links
>    1. mailto:pasik@xxxxxx
>    2. http://pasik.reaktio.net/fedora/xen-4.0.0-0.7.fc12.src.rpm
>    3. http://fedorapeople.org/~myoung/dom0/src/xen-4.0.0-0.7.fc12.src.rpm
>    4. http://xenbits.xen.org/xen-4.0-testing.hg
>    5. mailto:pasik@xxxxxx
>    6. http://wiki.xensource.com/xenwiki/XenParavirtOps
>    7. mailto:jeremy@xxxxxxxx
>    8. http://*xen*bits.*xen*.org/*xen*-*4.0*-testing.hg
>    9. http://xenbits.xen.org/xen-4.0-testing.hg
>   10. http://xenbits.xen.org/xen-4.0-testing.hg
>   11. http://*xen*bits.*xen*.org/*xen*-*4.0*-testing.hg
>   12. http://xenbits.xen.org/xen-4.0-testing.hg
>   13. http://xenbits.xen.org/xen-4.0-testing.hg
>   14. http://lists.xensource.com/xen-devel

TREND MICRO EMAIL NOTICE
The information contained in this email and any attachments is confidential and may be subject to copyright or other intellectual property protection. If you are not the intended recipient, you are not authorized to use or disclose this information, and we request that you notify us by reply mail or telephone and delete the original message from your mail system.
_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxxxxxxxx
http://lists.xensource.com/xen-devel