This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Reboot from OS will hang with pvops dom0 kernel

To: Sergey Kononenko <sergk@xxxxxxxxxxxx>
Subject: Re: [Xen-devel] Reboot from OS will hang with pvops dom0 kernel
From: Pasi Kärkkäinen <pasik@xxxxxx>
Date: Fri, 28 May 2010 13:48:33 +0300
Cc: Jeremy Fitzhardinge <jeremy@xxxxxxxx>, xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Fri, 28 May 2010 03:49:04 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20100528132612.6f6af5af@xxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <20100528132612.6f6af5af@xxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.18 (2008-05-17)
On Fri, May 28, 2010 at 01:26:12PM +0300, Sergey Kononenko wrote:
> Hi,
> I've encountered the same problem. After reboot machine went to sleep
> (or power off) mode, so I can't even reset it through IPMI, only
> powercycle (by IPMI too) works.
> I saw this problem only on new machine (Core i7 based, Xeon E5520,
> Supermicro X8DTL motherboard), but on Pentium D and Supermicro
> PDSMi reboot works.
> Also server hangs after reboot only with pvops Dom0 kernels (I
> tried stable-2.6.32.x and stable-2.6.33.x with hypervisors 3.4.3-rc and
> 4.0.0), but reboots normally with "Xenified" kernel (under
> 3.4.3-rc and 4.0.0 too). All kernels and hypervisors were built for
> x86-64 architecture.
> Changing BIOS settings related to ACPI and reboot didn't help.
> I tried all reboot= options in hypervisor command line: acpi, kbd,
> triple, but it didn't help when pvops kernels were used.

Are there any debug/error messages printed when/before it hangs? 

-- Pasi

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>