This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] blktap2 and pygrub: error

To: Xen-devel <xen-devel@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-devel] blktap2 and pygrub: error
From: eXeC001er <execooler@xxxxxxxxx>
Date: Thu, 20 May 2010 00:33:03 +0400
Delivery-date: Wed, 19 May 2010 13:47:32 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:received:date:message-id :subject:from:to:content-type; bh=I8gjCTrl3wBPCvg5V8GHj1X78+Hvncm19yNlIogqWvs=; b=mvPPZYbN489ij67eK3Dqs3gM/nbuJEIP4l0wuSkdxl2o7h+8ncrO7Deuqs9PD0H2u2 xqGRDViKiFS+TfIrW7mBHDdbR5QHVe6oyf6pm0Cdk30/obK7oD7C5HP7IpwtnA4iiCiG so68c8QDuvbCPkn7O2VXQCk3ppc0TJQnZblMc=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; b=kkvT0WQAes5qzRmCc2HtzV9JIuRbEVOwfDZ7J2jDn2UXjS7doqVKvG+drgW3GQPmEc 1Cs5PfaMuVYy5zO0RXutsUP65IkYXfBsHPUsg+nrQOaTcZHW6tl+1/525+CnzUdq0hCu eiInQUWLnD8thcvKsiP9GFO8E12y4tS1XPfB8=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx

I tried ti use VHD-disk-image for my Opensolaris DomU. 
Installation on this disk is fine, but i cannot to boot from it.

in logs "Disk isn't accessible";

I mount image and tried to use pygrub directly:

pygrub /dev/xvdp
Traceback (most recent call last):
  File "/usr/bin/pygrub", line 705, in <module>
    fs = fsimage.open(file, get_fs_offset(file))
IOError: [Errno 95] Operation not supported

but i can 'dd' from it device-file.

I researched this issue:

error returned from:
*** xen-src-root/tools/pygrub/src/fsimage/fsimage.c ***

static PyObject *
fsimage_open(PyObject *o, PyObject *args, PyObject *kwargs)
        static char *kwlist[] = { "name", "offset", "options", NULL };
        char *name;
        char *options = NULL;
        uint64_t offset = 0;
        fsimage_fs_t *fs;

        if (!PyArg_ParseTupleAndKeywords(args, kwargs, "s|Ls", kwlist,
            &name, &offset, &options))
                return (NULL);

        if ((fs = PyObject_NEW(fsimage_fs_t, &fsimage_fs_type)) == NULL)
                return (NULL);

        if ((fs->fs = fsi_open_fsimage(name, offset, options)) == NULL) {
                PyErr_SetFromErrno(PyExc_IOError);     <<<<<<<<<<<<<<<<<<<<<<<<
                return (NULL);

        return (PyObject *)fs;

*** xen-src-root/tools/libfsimage/common/fsimage.c ***
fsi_t *fsi_open_fsimage(const char *path, uint64_t off, const char *options)
        fsi_t *fsi = NULL;
        int fd;
        int err;

        if ((fd = open(path, O_RDONLY)) == -1)       <<<<<<<<<<<<<<<<<<<<<<
                goto fail;

        if ((fsi = malloc(sizeof(*fsi))) == NULL)
                goto fail;

        fsi->f_fd = fd;
        fsi->f_off = off;
        fsi->f_data = NULL;
        fsi->f_bootstring = NULL;

        err = find_plugin(fsi, path, options);
        if (err != 0)
                goto fail;

        return (fsi);

        err = errno;
        if (fd != -1)
                (void) close(fd);
        errno = err;
        return (NULL);

If i use 'file:/' type of disk-image (i have other disk-image) then all ok.
Xen-devel mailing list
<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-devel] blktap2 and pygrub: error, eXeC001er <=