This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Freeze on boot pv domU 2.6.31 with Xen 4.1

To: "Eric Chanudet (Intern)" <eric.chanudet@xxxxxxxxxx>
Subject: Re: [Xen-devel] Freeze on boot pv domU 2.6.31 with Xen 4.1
From: Jeremy Fitzhardinge <jeremy@xxxxxxxx>
Date: Wed, 19 May 2010 12:51:45 -0700
Cc: Steven Smith <Steven.Smith@xxxxxxxxxxxxx>, "xen-devel@xxxxxxxxxxxxxxxxxxx" <xen-devel@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Wed, 19 May 2010 12:53:28 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <8D3CF83526F4304BA2F3C06F0DAB482E7B9FC46A33@xxxxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <8D3CF83526F4304BA2F3C06F0DAB482E7B9FC46A33@xxxxxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20100430 Fedora/3.0.4-2.fc12 Lightning/1.0b2pre Thunderbird/3.0.4
On 05/19/2010 11:55 AM, Eric Chanudet (Intern) wrote:
> I am trying to run a PV domU with netchannel2.
> I used to achieve this with the kernel from xen/stable-2.6.31.x on 
> linux-2.6-pvops repository. It does not work anymore, and does not seem to 
> have any relation with netchannel2 (since I tried to remove it from my 
> .config for testing purpose).
> The kernel basically freezes while booting. No error displayed, neither on 
> dom0 serial output (Xen in debug mode), or kernel one's. It just freezes 
> after :
> [    0.000999] xen_balloon: Initialising balloon driver with page order 0.
> [    0.000999] SCSI subsystem initialized
> [    0.000999] usbcore: registered new interface driver usbfs
> [    0.000999] usbcore: registered new interface driver hub
> [    0.000999] usbcore: registered new device driver usb
> [    0.000999] PCI: System does not support PCI
> [    0.000999] PCI: System does not support PCI

Make sure you have "console=hvc0 earlyprintk=xen ignore_loglevel
initcall_debug" on your guest kernel command line to see if we can get
some idea of where its getting up to.

> I'm using the same kernel, with privileged domain configuration, as dom0 
> (2.6.31) on Xen-4.1 last revision.
> I tried 2.6.32 and 2.6.33 for the pv domU, these ones achieve to boot, but do 
> not support netchannel2.
> Since I just want to have a pv kernel handling netchannel2, can anyone advise 
> me a way ?

You're the first person I know to try nc2 in a pvops kernel, so I'm not
surprised you're encountering difficulties.


Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>