This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] Problems upgrading 3.4 to 4.0? WAS: Xen on vmware

To: eXeC001er <execooler@xxxxxxxxx>, Xen-devel <xen-devel@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-devel] Problems upgrading 3.4 to 4.0? WAS: Xen on vmware
From: Dan Magenheimer <dan.magenheimer@xxxxxxxxxx>
Date: Wed, 5 May 2010 16:14:44 -0700 (PDT)
Delivery-date: Wed, 05 May 2010 16:17:15 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <v2pebc0b6391004230843s8f762b9bu2c3ac077ccea763f@xxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <v2pebc0b6391004230843s8f762b9bu2c3ac077ccea763f@xxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx

Hmmm... I am having the same problem BUT not on VMware.


I built and installed xen-4.0.0.tar.gz on a xen-3.4 based system (Oracle VM) and got the same problem (xc.xeninfo not implemented).  (Yes, I built and installed tools and dom0 (2.6.18-xen) too.)


Then I tried xen-4.0-testing.hg  and got the same thing.


I wonder if there’s some 3.4 residue that is screwing up 4.0 installs?


I hate to reinstall the whole system from scratch, but I can if necessary.


From: eXeC001er [mailto:execooler@xxxxxxxxx]
Sent: Friday, April 23, 2010 9:43 AM
To: Xen-devel
Subject: [Xen-devel] Xen on vmware




I tried to start Xen Dom0 in vmware virtual machine (Debian Squeeze).


xen-tools from xen-unstable.


xen-4.1 (from mercurial xen-unstable) - PASS (kernel, hypervisor, xend)


xen-3.4 (from Debian Squeeze) - FAIL (kernel (PASS), hypervisor (PASS), xend (FAIL))



[2010-04-23 03:01:35 1472] INFO (SrvDaemon:332) Xend Daemon started

[2010-04-23 03:01:35 1472] ERROR (SrvDaemon:349) Exception starting xend ((38, 'Function not implemented'))

Traceback (most recent call last):

  File "usr/lib/python2.5/site-packages/xen/xend/server/SrvDaemon.py", line 335, in run

    xinfo = xc.xeninfo()

Error: (38, 'Function not implemented')

[2010-04-23 03:01:35 1471] INFO (SrvDaemon:220) Xend exited with status 1.



What is the difference?


p.s.: xen-tools from xen-unstable and xen-3.4 works fine on bare-metal



Xen-devel mailing list
<Prev in Thread] Current Thread [Next in Thread>