This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] Use of xend-pci-permissive.sxp

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] Use of xend-pci-permissive.sxp
From: David Gonzalez <info@xxxxxxxxxxx>
Date: Fri, 18 Dec 2009 04:48:01 -0500
Delivery-date: Mon, 21 Dec 2009 08:44:39 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Hi xen developers,

You're the best, Xen Rulez. Although I've subscribed to xen's mailing list I post and I never get an answer, I hope this time this mail went somewhere.

I've PV'ed CentOS 5.3 i386 as DomU with CentOS 5.4 x86_64 as Dom0. I have this OpenVox Telephony card (Openvox A1200P with 1 FXS and 1 FXO modules). I want to use on the Virtualized OS, I ahd to twak a lot to get it running, and I had to use the xend-pci-permissive.sxp because the dreaded "driver tried to write...."

lspci on my Dom0 says:

01:09.0 Communication controller: Tiger Jet Network Inc. Tiger3XX Modem/ISDN interface
        Subsystem: Unknown device 9100:0003
        Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin A routed to IRQ 21
        Region 0: I/O ports at e800 [disabled] [size=256]
        Region 1: Memory at fcfff000 (32-bit, non-prefetchable) [disabled] [size=4K]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk- DSI+ D1- D2+ AuxCurrent=55mA PME(D0+,D1-,D2+,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

pciback 0000:13:04.0: Driver tried to write to a read-only configuration space field at offset 0xe0, size 2. This may be harmless, but if you have problems with your device:
1) see permissive attribute in sysfs
2) report problems to the xen-devel mailing list along with details of your device obtained from lspci.
PCI: Enabling device 0000:13:04.0 (0000 -> 0003)
Although Now I see the device on DomU, whenever I try to load the DAHDI 2.2.0 drivers I get this on dmesg on Dom0, and it hangs to death after some time.

Do you have a strange power saving mode enabled?
Uhhuh. NMI received for unknown reason 00.
Dazed and confused, but trying to continue
Do you have a strange power saving mode enabled?

Anyway, The only way to solve this issue was to use xend-pci-permissive.sxp adding:

     ('e159:0001') # OpenVox A1200P

Hope this helps you

Thanks again.

David Gonzalez H.
Phone Bogotá: +(57-1)289-1168
Phone Medellin: +(57-4)247-0985
Mobile: +(57)315-838-8326
MSN: david@xxxxxxxxxxxxxxxx
Skype: davidgonzalezh
WEB: http://www.dghvoip.com/
Proud Linux User #294661

Xen-devel mailing list
<Prev in Thread] Current Thread [Next in Thread>