This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-devel] pv 2.6.31 (kernel.org) and save/migrate

To: "Pasi Kärkkäinen" <pasik@xxxxxx>
Subject: RE: [Xen-devel] pv 2.6.31 (kernel.org) and save/migrate
From: Dan Magenheimer <dan.magenheimer@xxxxxxxxxx>
Date: Fri, 6 Nov 2009 14:27:27 -0800 (PST)
Cc: "Xen-Devel \(E-mail\)" <xen-devel@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Fri, 06 Nov 2009 14:29:08 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20091106203720.GZ1434@xxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
> On Fri, Nov 06, 2009 at 10:37:49AM -0800, Dan Magenheimer wrote:
> > Sorry for another possibly stupid question:
> > 
> > I've observed that for a pv domain that's been updated
> > to a 2.6.31 kernel (straight from kernel.org), "xm save"
> > never completes.  When the older kernel (2.6.18)
> > is booted, "xm save" works fine.  Is this a known problem...
> > or perhaps xm save has never worked with an upstream pv
> > kernel and I've never noticed?
> > 
> > I'd assume migrate and live migrate would fail also but
> > haven't tried them.
> > 
> Just checking.. are you running the latest ? I think 
> there has
> been multiple xen related bugfixes in the 2.6.31.X releases.
> -- Pasi

No it was plain 2.6.31.  But I downloaded/built and
can't even get it to boot (and no console or VNC output at
all).  Are CONFIG changes required betwen 2.6.31 and
for Xen?  (I checked and I am using the same .config.)

Trying to reproduce on a different machine, just to verify.


Xen-devel mailing list