This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Re: Using Xen Virtualization Environment for Development

To: Pasi Kärkkäinen <pasik@xxxxxx>
Subject: Re: [Xen-devel] Re: Using Xen Virtualization Environment for Development and Testing of Supercomputing and High Performance Computing (HPC) Cluster MPICH2 MPI-2 Applications
From: Jeremy Fitzhardinge <jeremy@xxxxxxxx>
Date: Fri, 30 Oct 2009 08:22:11 -0700
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx, "Mr. Teo En Ming \(Zhang Enming\)" <space.time.universe@xxxxxxxxx>, xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Fri, 30 Oct 2009 08:42:22 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20091030094943.GL1434@xxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <f712b9cf0910292337k5247e737pea271b244c340e16@xxxxxxxxxxxxxx> <f712b9cf0910292353u1239ed74rf6012620519dc17e@xxxxxxxxxxxxxx> <f712b9cf0910300053j782151f7y6f7084b3b3a59c62@xxxxxxxxxxxxxx> <f712b9cf0910300112g528ce37ar41e9fa4710f1571@xxxxxxxxxxxxxx> <f712b9cf0910300135k79c47ac2k6d48f191cc1fd9a6@xxxxxxxxxxxxxx> <20091030094943.GL1434@xxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20091014 Fedora/3.0-2.8.b4.fc11 Lightning/1.0pre Thunderbird/3.0b4
On 10/30/09 02:49, Pasi Kärkkäinen wrote:
> On Fri, Oct 30, 2009 at 04:35:00PM +0800, Mr. Teo En Ming (Zhang Enming) 
> wrote:
>>    Dear All,
>>    I have solved the problem.
>>    With reference to
>> [1]http://lists.xensource.com/archives/html/xen-devel/2009-05/msg01327.html
>>    and
>> [2]http://hightechsorcery.com/2008/03/virtualization-tip-always-disable-checksumming-virtual-ethernet-devices
>>    , I have executed the following command as root on all my 6 compute nodes
>>    (each compute node is a F11 linux 64-bit PV virtual machine).
>>    # ethtool -K eth0 tx off gso on
> Jeremy: Do you know why this is still needed nowadays? 
> Where's the bug? Why doesn't it work with the defaults? 

I committed bugfix relating to gso/tso a couple of days ago, so I think
(hope!) this shouldn't be necessary any more.


Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>