This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Failure to setup Xen 3.4.1 Dom0 on top of Ubuntu 9.10 Se

To: "xen-devel@xxxxxxxxxxxxxxxxxxx" <xen-devel@xxxxxxxxxxxxxxxxxxx>, Keir Fraser <keir.fraser@xxxxxxxxxxxxx>
Subject: Re: [Xen-devel] Failure to setup Xen 3.4.1 Dom0 on top of Ubuntu 9.10 Server HVM DomU ( xenified kernel)
From: Boris Derzhavets <bderzhavets@xxxxxxxxx>
Date: Sun, 30 Aug 2009 06:19:18 -0700 (PDT)
Delivery-date: Sun, 30 Aug 2009 06:19:47 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=yahoo.com; s=s1024; t=1251638359; bh=+12fU+xdKvO+nfahWJg2br8sFVCw6hurS6YBLRKqbHw=; h=Message-ID:X-YMail-OSG:Received:X-Mailer:Date:From:Subject:To:In-Reply-To:MIME-Version:Content-Type; b=WonInn/9FGdMNh5mz3mUMFPNqGmZJyM3QZGnsPANta6yoUySnbzQFKhjCAEO8lOz/YRDTrO98tNrutbEWaYblFDaUcx4BmNPDyzgavgPCPwB2WDlbOM9QP5s4riw6SKyw0JlqPbXeis8++ZEZcXlfShYb2veWY/pWbhOxrOGMtI=
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.com; h=Message-ID:X-YMail-OSG:Received:X-Mailer:Date:From:Subject:To:In-Reply-To:MIME-Version:Content-Type; b=VmvAo2VLhDTO24c05jKBdIP3xiXBJ9icPy2udbqPrDKBg8d8v5LEl++TUBuAOt5D/fJCMOGHsZ3vFdkVrwmUwlj761KrE7Q2B0a0QE2wNUgHReb8EpAnrAL0tcOuybyQxSYRq6skSdXejHQN8+dUjpLMIj9VKByy36H1acLiCHc=;
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <C6C032BB.138BB%keir.fraser@xxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
> no Xen developer has tested GRUB2

Googling clearly shows , that a lot of Xen USERS have
been experienced similar issues on Debian 5 aka Lenny.
However , workaround seems to be Debian dependent  -
-  http://www.mail-archive.com/grub-devel@xxxxxxx/msg10870.html

For now i just add to kernel boot command line :-

pressing F6 at startup menu allows to modify linux boot command line
and get Ubuntu 9.10 Server installed with legacy grub.


--- On Sun, 8/30/09, Keir Fraser <keir.fraser@xxxxxxxxxxxxx> wrote:

From: Keir Fraser <keir.fraser@xxxxxxxxxxxxx>
Subject: Re: [Xen-devel] Failure to setup Xen 3.4.1 Dom0 on top of Ubuntu 9.10 Server HVM DomU ( xenified kernel)
To: "Boris Derzhavets" <bderzhavets@xxxxxxxxx>, "xen-devel@xxxxxxxxxxxxxxxxxxx" <xen-devel@xxxxxxxxxxxxxxxxxxx>
Date: Sunday, August 30, 2009, 8:44 AM

On 30/08/2009 10:32, "Boris Derzhavets" <bderzhavets@xxxxxxxxx> wrote:

> Directive "root=UUID=...." switched off via editing /etc/default/grub and
> update-grub
> run.
> Seems to be Grub2's  multiboot implementation issue.
>  Grub2 breaks backward compatibility in meantime per my opinion.
> Please, advise if i am wrong about that.

Well, it might be a bug in Xen's interpretation of the multiboot spec of
course. The basic issue is that no Xen developer has tested GRUB2, and no
GRUB2 developer has tested Xen. :-) No doubt this will get fixed if GRUB2
gains traction.

-- Keir

Xen-devel mailing list
<Prev in Thread] Current Thread [Next in Thread>