This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] Xen and OCFS interoperability issue

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] Xen and OCFS interoperability issue
From: Gonçalo Borges <goncalo@xxxxxx>
Date: Tue, 25 Aug 2009 13:33:55 +0100
Delivery-date: Tue, 25 Aug 2009 05:34:22 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Organization: LIP
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20090814 Fedora/3.0-2.6.b3.fc11 Thunderbird/3.0b3
Hi Xen devel people...

I've sent the following message to xen-users mailing list with no feedback.
Indeed, it seems more of a devel issue, than a user one.

Can someone of you shed some light in here?

Cheers and Thanks

Hi All...

I'm testing a Xen solution on an OCFS2 SAN to store VM images.

If I try to save a VM asking to store the file in any Dom0 local dir
(ex: /tmp) everything works fine, and I can properly restore the VM
afterwards. Nevertheless, It I try to save a VM asking to store the
saved file inside the OCFS2 SAN, it fails with the following messages in


[2009-08-21 14:45:25 xend 9720] DEBUG (XendCheckpoint:89) [xc_save]:
/usr/lib64/xen/bin/xc_save 26 9 0 0 0
[2009-08-21 14:45:25 xend 9720] DEBUG (XendCheckpoint:322) suspend
[2009-08-21 14:45:25 xend 9720] DEBUG (XendCheckpoint:92) In
saveInputHandler suspend
[2009-08-21 14:45:25 xend 9720] DEBUG (XendCheckpoint:94) Suspending 9 ...
[2009-08-21 14:45:25 xend.XendDomainInfo 9720] DEBUG
(XendDomainInfo:1036) XendDomainInfo.handleShutdownWatch
[2009-08-21 14:45:25 xend.XendDomainInfo 9720] DEBUG
(XendDomainInfo:1036) XendDomainInfo.handleShutdownWatch
[2009-08-21 14:45:25 xend.XendDomainInfo 9720] INFO (XendDomainInfo:994)
Domain has shutdown: name=migrating-one-0 id=9 reason=suspend.
[2009-08-21 14:45:25 xend 9720] INFO (XendCheckpoint:99) Domain 9 suspended.
[2009-08-21 14:45:25 xend 9720] DEBUG (XendCheckpoint:108) Written done
[2009-08-21 14:45:25 xend 9720] INFO (XendCheckpoint:351) Had 0
unexplained entries in p2m table
[2009-08-21 14:45:25 xend 9720] INFO (XendCheckpoint:351) Saving memory
pages: iter 1   0%ERROR Internal error: Error when writing to state file
(5) (errno 14)
[2009-08-21 14:45:25 xend 9720] INFO (XendCheckpoint:351) Save exit rc=1
[2009-08-21 14:45:25 xend 9720] ERROR (XendCheckpoint:133) Save failed
on domain one-0 (9).
Traceback (most recent call last):
   File "/usr/lib64/python2.4/site-packages/xen/xend/XendCheckpoint.py",
line 110, in save
     forkHelper(cmd, fd, saveInputHandler, False)
   File "/usr/lib64/python2.4/site-packages/xen/xend/XendCheckpoint.py",
line 339, in forkHelper
     raise XendError("%s failed" % string.join(cmd))
XendError: /usr/lib64/xen/bin/xc_save 26 9 0 0 0 failed


It seems I'm not the only one complaining about this issue, according to
the following threads:


I wonder is there is some workaround for the problem?


Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-devel] Xen and OCFS interoperability issue, Gonçalo Borges <=