This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Xen Paravirt Operations Domain 0 Serial Console Problem

To: enming.teo@xxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] Xen Paravirt Operations Domain 0 Serial Console Problem
From: "Mr. Teo En Ming (Zhang Enming)" <enming.teo@xxxxxxxxxxxxxxx>
Date: Tue, 25 Aug 2009 00:21:19 +0800
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Mon, 24 Aug 2009 09:21:46 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4A92BD31.2040406@xxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <4A92BD31.2040406@xxxxxxxxxxxxxxx>
Reply-to: enming.teo@xxxxxxxxxxxxxxx
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20090814 Fedora/3.0-2.6.b3.fc11 Thunderbird/3.0b3

The main purpose of doing this is that I want to boot using serial console and free up the VGA card for direct access by the Windows HVM guest using VT-d IOMMU. But it seems I cannot get serial console working.

Please advise.

Thank you.

Mr. Teo En Ming (Zhang Enming) Dip(Mechatronics Engineering) 
BEng(Hons)(Mechanical Engineering)
Technical Support Engineer
Information Technology Department
Asiasoft Online Pte Ltd
Tampines Central 1 #04-01 Tampines Plaza
Singapore 529541
Republic of Singapore
Mobile: +65-9648-9798
MSN: teoenming@xxxxxxxxxxx
Alma Maters: Singapore Polytechnic, National University of Singapore

On 08/25/2009 12:17 AM, Mr. Teo En Ming (Zhang Enming) wrote:
Hi All,

I have tried to configure serial console for Xen hypervisor, dom 0 kernel and Linux login but it does not seem to be working.

Here is my grub configuration for serial console:

title Fedora (2.6.31-rc6-enming.teo) Serial Console
        root (hd0,0)
        kernel /xen.gz iommu=1 com1=115200,8n1 console=com1
module /vmlinuz-2.6.31-rc6-enming.teo ro root=/dev/mapper/vg_fedora11_host-lv_root selinux=0 console=ttyS0,115200
        module /initrd-2.6.31-rc6-enming.teo.img

Is the above configuration correct? On my Intel Desktop Board DQ45CB, I have a COM1 header on the PCB and I have connected an external serial port to this header and also enabled COM1 in the BIOS.

After selecting the above entry in GRUB still on VGA, a cursor at the top left corner of the monitor shows up, which means Xen and Dom 0 kernel are booting up on the serial console and not on VGA.

However, after some time, a login prompt finally displays on my VGA monitor! Isn't it NOT supposed to show up on VGA and should show up in serial console instead?

All the while I get nothing displayed on the Windows laptop connected to the serial console of the Xen machine. I am using Windows Hyper Terminal with a null modem cable and a USB-to-Serial converter cable.

After seeing nothing on Hyper Terminal, I go to the VGA console (tty1) and keyboard and pressed CTRL-ALT-DEL to reboot the Xen machine.

Then finally I see this screenshot:


After that, I select rebooting using serial console but I still see nothing on Hyper Terminal.

May I know what's happening and what's wrong with serial console?

Thank you.

Xen-devel mailing list