This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] pvops dom0 work roadmap / Fedora 11 libvirt problems wit

To: Boris Derzhavets <bderzhavets@xxxxxxxxx>
Subject: Re: [Xen-devel] pvops dom0 work roadmap / Fedora 11 libvirt problems with Xen 3.4
From: Pasi Kärkkäinen <pasik@xxxxxx>
Date: Wed, 19 Aug 2009 10:09:35 +0300
Cc: Xen-devel <xen-devel@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Wed, 19 Aug 2009 00:10:23 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <379098.33518.qm@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <20090818224117.GJ19938@xxxxxxxxxxxxxxx> <379098.33518.qm@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.13 (2006-08-11)
On Tue, Aug 18, 2009 at 09:16:08PM -0700, Boris Derzhavets wrote:
> >There was a bug in libvirt of F11 dom0 causing virt-viewer to crash when 
> > using Xen 3.4, but after I got that patched it was all fine
> If it's possible to share your experience , i wonder does it mean, that  
> you've got xen-3.4.0-2.fc12.src.rpm working on F11 (32-bit) ?
> I was unable to connect to xend when starting virt-manager after 
> xen-3.4.0-2.fc12.src.rpm install ( along with generated packages) on 64-bit 
> F11 instance.

I grabbed Xen 3.4.1-1 src.rpm from:

and rebuilt that for F11.

The next problem was that libvirt package in Fedora 11 has a bug, which causes 
to crash (segfault) when virt-viewer is started. This crash only happens with 
Xen 3.4, not with Xen 3.3.

Patch for the libvirt bug is here:

Upcoming libvirt update for F11 will fix this. After manually applying that
patch and rebuilding libvirt I'm now able to successfully install new guests
using virt-install and connect to their console by virt-viewer.

-- Pasi

Xen-devel mailing list