This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] What is the current state of Dom0 kernel support? / cras

To: Pasi Kärkkäinen <pasik@xxxxxx>
Subject: Re: [Xen-devel] What is the current state of Dom0 kernel support? / crash with 2.6.31-rc5 32bit PAE
From: Jeremy Fitzhardinge <jeremy@xxxxxxxx>
Date: Thu, 13 Aug 2009 13:17:40 -0700
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Thu, 13 Aug 2009 13:18:10 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20090811195844.GJ24960@xxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <20090722193530.GR24960@xxxxxxxxxxxxxxx> <20090722195748.GS24960@xxxxxxxxxxxxxxx> <4A6775C9.5010802@xxxxxxxx> <20090722205346.GU24960@xxxxxxxxxxxxxxx> <4A70B585.2070109@xxxxxxxx> <20090730084800.GT24960@xxxxxxxxxxxxxxx> <20090730113532.GV24960@xxxxxxxxxxxxxxx> <20090810164330.GA24960@xxxxxxxxxxxxxxx> <4A805053.5010509@xxxxxxxx> <20090810192750.GF24960@xxxxxxxxxxxxxxx> <20090811195844.GJ24960@xxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b3pre) Gecko/20090513 Fedora/3.0-2.3.beta2.fc11 Lightning/1.0pre Thunderbird/3.0b2
On 08/11/09 12:58, Pasi Kärkkäinen wrote:
> I just added some debug printk()'s to the very beginning of the function and 
> found out this:
> DEBUG active_evtchns: cpu: 0, sh: 4117237760, idx: 0
> DEBUG sh->evtchn_pending: 4117239808, sh->evtchn_mask: 4117239936
> DEBUG cpu_evtchn_mask(cpu): 0
> so.. looks like the buggy piece of code (null pointer dereference) is: 
> cpu_evtchn_mask(cpu)[idx]

I pushed something that looks like a fix for this.  Please tell me how
it goes.


Xen-devel mailing list