This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-devel] HVM guest sees two NICs even though just one vif configu

On Thu, 6 Aug 2009, Fischer, Anna wrote:
> > Subject: Re: [Xen-devel] HVM guest sees two NICs even though just one
> > vif configured
> > 
> > On 06/08/2009 10:32, "Fischer, Anna" <anna.fischer@xxxxxx> wrote:
> > 
> > > For me this does not sound right. If I configure my guest with only a
> > single
> > > NIC in the configuration file, then there should not be any way for
> > the guest
> > > to set up and use two NICs at the same time.
> > >
> > > Is this a known issue? How is this supposed to be handled?
> > 
> > I think it's deliberate, to allow install of an OS with emulated
> > driver,
> > followed by switchover to PV drivers, wth no need for config changes.
> I assumed that was the reason behind this. However, a switchover would need 
> to guarantee that a guest cannot use two NICs at the same time, doesn't it? 
> Because otherwise the guest can send out of two separate devices at the same 
> time and it could cause unexpected behaviour unless it is explicitly 
> prevented at the backends in Dom0, e.g. through filtering or anti-spoofing I 
> guess.

I more recent qemu allows the pv drivers in the guest to disconnect the
emulated devices to avoid these problems.

Xen-devel mailing list