This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] xen client initiative compile errors

To: Ben Guthro <ben.guthro@xxxxxxxxxxxxxxxxxxx>
Subject: Re: [Xen-devel] xen client initiative compile errors
From: Gary Grebus <ggrebus@xxxxxxxxxxxxxxx>
Date: Fri, 03 Apr 2009 15:43:07 -0400
Cc: Xen-Devel <xen-devel@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Fri, 03 Apr 2009 12:43:39 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <1238773264.6535.64.camel@bguthro-desktop>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <1238773264.6535.64.camel@bguthro-desktop>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
On Fri, 2009-04-03 at 11:41 -0400, Ben Guthro wrote:
> So...I'm trying to build the xen client initiative code found here:
> http://xenbits.xen.org/xenclient/
> However, I'm running into compile errors:
>  gcc -I../byterun -DCAML_NAME_SPACE -DNATIVE_CODE -DTARGET_amd64
> -fno-stack-protector   -c -o signals_asm.o signals_asm.c
> signals_asm.c: In function 'segv_handler':
> signals_asm.c:188: error: 'REG_CR2' undeclared (first use in this
> function)
> signals_asm.c:188: error: (Each undeclared identifier is reported only
> once
> signals_asm.c:188: error: for each function it appears in.)
> signals_asm.c:194: error: 'REG_RIP' undeclared (first use in this
> function)
> signals_asm.c:199: error: 'REG_R14' undeclared (first use in this
> function)
> signals_asm.c:200: error: 'REG_R15' undeclared (first use in this
> function)
> make[3]: *** [signals_asm.o] Error 1
> Am I missing something in my build environment that the configure
> scripts didn't complain about? 
> I'm building on Ubuntu 8.04 (gcc 4.2.4)

It's trying to build a binary using the 32-bit uclibc targeted compiler
(from the toolchain build), but it's configured as if building for the
64 bit native environment (-DTARGET_amd64 -DSYS_linux).

I tried overriding the ARCH and SYSTEM for that target on the
appropriate make command in package/xenclient/ocaml/ocaml.mk but the
build failed later trying to run the assembler (running native vs.
toolchain version?).

At that point I punted and tried building in a 32-bit Fedora 10

It goes wrong later trying to download the version of grub specified in
target/x86/grub2/grub2.mk.  That version doesn't appear to be on the
debian mirrors anymore, so I tried the next newer version:


Everything built successfully, but then I run into problems executing
the last step of the manual install process.  The install-bootloader
script errors out running grub-install.  The grub-install command

error: cannot seek `/dev/sda'         
error: cannot seek `/dev/sda'         
grub-probe: error: no mapping exists for `xenclient-config'

... and

stat: invalid option -- c
BusyBox v1.13.1 (2009-04-02 20:55:22 EDT) multi-call binary

Usage: stat [OPTION] FILE...

Display file (default) or filesystem status

        -f      Display filesystem status
        -L      Dereference links
        -t      Display info in terse form

I'd guess that's a problem with the different version of grub, but I
could had something else wrong too.


> Has anyone else run into this issue?
> B
> _______________________________________________
> Xen-devel mailing list
> Xen-devel@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-devel

Xen-devel mailing list