This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Failure to setup VNC at CentOS 5.2 PV DomU at Xen Unstab

To: Jeremy Fitzhardinge <jeremy@xxxxxxxx>
Subject: Re: [Xen-devel] Failure to setup VNC at CentOS 5.2 PV DomU at Xen Unstable ( 2.6.29-rc8 kernel)
From: Boris Derzhavets <bderzhavets@xxxxxxxxx>
Date: Thu, 26 Mar 2009 09:14:53 -0700 (PDT)
Cc: Xen-devel <xen-devel@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Thu, 26 Mar 2009 09:15:24 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=yahoo.com; s=s1024; t=1238084093; bh=yU88Hu5ERhnBhR36qfgvj4HEGfLjbnPBkFkbUCqPnzA=; h=Message-ID:X-YMail-OSG:Received:X-Mailer:Date:From:Reply-To:Subject:To:Cc:In-Reply-To:MIME-Version:Content-Type; b=PXUed0AA6Du6AYqNSCgkmIflbBs87n2y0AN22uStPlgRZDW3jYDIZy+N2XG7MFZh51dA/eISiPb/TQtSm92xW7qGHgnOMhT1pWgEdPGlr6A2U+QbwWcL5T4PKUzRU1opDEbPgT4Lxs96euJBf7XQzC0Tb+SdXD1pwV0Q2HhePok=
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.com; h=Message-ID:X-YMail-OSG:Received:X-Mailer:Date:From:Reply-To:Subject:To:Cc:In-Reply-To:MIME-Version:Content-Type; b=ssxjI7VkK3jDlatgnSBRGgxTtSG9iFYeDfVORxOxU6LGhV/tTDnY/EddkqWoptMm/LZY8+hv2hA8FGA3coPTWNSJMsvYttt4vgWZ+K+0SjrcHE6Y8omSSfApCBQIp21jxmLdXTV0aFziDoOU0CUuJ3LO/zDVHCphRty064qMd/g=;
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <510750.11906.qm@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Reply-to: bderzhavets@xxxxxxxxx
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
I believe i  have  to describe the issue in more details:-
1. Xen Unstable Dom0 with 2.6.29-rc8 pvops kernel is installed on top
of Ubuntu 8.10 Server with ubuntu desktop up and running. GDM service is running,
with gdm.conf configured to allow remote connections, xinetd is running Xvnc configured for remote connection as well.
2. This configuration  provides remote connection to Dom0 with pvops kernel via Gnome Desktop. Crash happens when i run VNC session opened via gnome terminal at remote Dom0's desktop ( it worked fine with rc5 or rc6 for sure).
If i ussue :-
# vncviewer IP_DomU:1
from gnome terminal running on remote host (i.e. without any interaction with Ubuntu
specific X-Server clients services)  VNC session seems to be running stable.


--- On Thu, 3/26/09, Boris Derzhavets <bderzhavets@xxxxxxxxx> wrote:
From: Boris Derzhavets <bderzhavets@xxxxxxxxx>
Subject: [Xen-devel] Failure to setup VNC at CentOS 5.2 PV DomU at Xen Unstable ( 2.6.29-rc8 kernel)
To: "Jeremy Fitzhardinge" <jeremy@xxxxxxxx>
Cc: "Xen-devel" <xen-devel@xxxxxxxxxxxxxxxxxxx>
Date: Thursday, March 26, 2009, 10:54 AM

Occasionally during VNC session CentOS 5.2 PV DomU crashes
Attempt to restart it remind hotplug scripts issue . Stack trace upon the crash during VNC session :-

Unable to handle kernel NULL pointer dereference at 000000000000013f RIP:
 [<ffffffff88110a37>] :xennet:network_tx_buf_gc+0xea/0x1cf
PGD 742b8067 PUD 7429c067 PMD 0
Oops: 0002 [1] SMP
last sysfs file: /block/dm-1/range
Modules linked in: ipv6 xfrm_nalgo crypto_api autofs4 hidp rfcomm l2cap bluetooth sunrpc xennet
dm_multipath parport_pc lp parport pcspkr dm_snapshot dm_zero dm_mirror dm_mod xenblk ext3 jbd uhci_hcd ohci_hcd ehci_hcd
Pid: 0, comm: swapper Not tainted 2.6.18-92.1.22.el5xen #1
RIP: e030:[<ffffffff88110a37>]  [<ffffffff88110a37>] :xennet:network_tx_buf_gc+0xea/0x1cf
RSP: e02b:ffffffff8062fe78  EFLAGS: 00010046
RAX: 0000000000000078 RBX: ffff88007d438500 RCX: 0000000000000000
RDX: 000000000000006f RSI: 0000000000000000 RDI: ffff88007d439670
RBP: 0000000000000073 R08: ffffc20000000000 R09: 00000000ffff61ae
R10: ffff880075e4fac0 R11: 0000000000000246 R12: 000000000000006f
R13: ffff88007d438000 R14: 0000000000000fd0 R15: 0000000000000fcf
FS:  00002b8fc16d62d0(0000) GS:ffffffff805b0000(0000) knlGS:0000000000000000
CS:  e033 DS: 0000 ES: 0000
Process swapper (pid: 0, threadinfo ffffffff805f0000, task ffffffff804d8b00)
Stack:  0000006f00000001  ffff88007d438000  ffff88007d438500  0000000000000000
 0000000000000109  ffffffff805f1ea8  ffffffff805f1ea8  ffffffff88111d46
 ffff88007f1cfac0  0000000000000000
Call Trace:
 <IRQ>  [<ffffffff88111d46>] :xennet:netif_int+0x2c/0x72
 [<ffffffff802112c1>] handle_IRQ_event+0x2d/0x60
 [<ffffffff802b1af5>] __do_IRQ+0xa4/0x103
 [<ffffffff8028fd9d>] _local_bh_enable+0x61/0xc5
 [<ffffffff8026db48>] do_IRQ+0xe7/0xf5
 [<ffffffff803a0c69>] evtchn_do_upcall+0x86/0xe0
 [<ffffffff802608d6>] do_hypervisor_callback+0x1e/0x2c
 <EOI>  [<ffffffff802063aa>] hypercall_page+0x3aa/0x1000
 [<ffffffff802063aa>] hypercall_page+0x3aa/0x1000
 [<ffffffff8026f139>] raw_safe_halt+0x84/0xa8
 [<ffffffff8026c683>] xen_idle+0x38/0x4a
 [<ffffffff8024aa8e>] cpu_idle+0x97/0xba
 [<ffffffff805fab09>] start_kernel+0x21f/0x224

Attempt to restart CentOS 5.2 PV DomU

Scanning and configuring dmraid supported devices
Scanning logical volumes
  Reading all physical volumes.  This may take a while...
  No volume groups found
Activating logical volumes
  Volume group "VolGroup00" not found
Creating root device.
Mounting root filesystem.
mount: could not find filesystem '/dev/root'
Setting up other filesystems.
Setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!
 root@ServerIntrepid:/home/boris/vm# Error: Device 0 (vif) could not be connected. Hotplug scripts not working.

F10 PV DomU also cannot be started after the accident due to Hotplug scripts not working.

VNC at Linux DomUs  worked fine with rc5 as far as i remember.


Xen-devel mailing list

Xen-devel mailing list