This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] RE: Hot plug scripts not working c/s 19355 (was: Re: [PATCH]

To: Jeremy Fitzhardinge <jeremy@xxxxxxxx>, Keir Fraser <keir.fraser@xxxxxxxxxxxxx>
Subject: [Xen-devel] RE: Hot plug scripts not working c/s 19355 (was: Re: [PATCH] xen: mask XSAVE in cpuid since we don't allow guests to use it)
From: Dan Magenheimer <dan.magenheimer@xxxxxxxxxx>
Date: Mon, 16 Mar 2009 17:17:57 +0000 (GMT)
Cc: bderzhavets@xxxxxxxxx, Xen-devel <xen-devel@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Mon, 16 Mar 2009 10:19:05 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <49BA932E.7000907@xxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
> Any chance you could try to pinpoint the failing version?

> > You could try reverting changeset 19342, as most likely culprit.

Well I've been struggling with this on and off since Friday and
am having major problems because there are now many parts that
I'm no longer sure how to synchronize.  The tools now seem to
be dependent on ioemu but I don't know how (or if its possible)
to synchronize versions of the ioemu git tree with a specific
xen hg changeset.  Rolling xen tools back to 19187 worked fine,
but I couldn't roll the tools back to tip due to a compile error

ioemu-dir/hw/pt-msi.c:95: error: too few arguments to xc_domain_update_msi_irq

I did a git pull in ioemu-dir and no longer got the compile error
but it didn't help (same hotplug problem) and now I can't rollback
xen tools to 19187 because I get the opposite compile error.
So my test machine, which HAD been working at least with tools 19187
is now useless unless I solve the problem.

(BTW, I tried reverting 19342 and it didn't solve the problem.)

I was able to do a fresh tip build and install on a new test machine
(that previously had no xen on it at all), so I suspect my problem was
due to a mismatch between dom0 and "something else" so am now in the
process of rebuilding dom0 from latest.

Argh!  I thought bisecting was supposed to be easy!

With so many interdependent parts (and two different change-tracking
tools needed), perhaps its time to start being more careful about
describing version interdependencies between them?

Or maybe if I were sufficiently knowledgeable about both mercurial
and git, this wouldn't be a problem?

> -----Original Message-----
> From: Jeremy Fitzhardinge [mailto:jeremy@xxxxxxxx]
> Sent: Friday, March 13, 2009 11:09 AM
> To: Keir Fraser
> Cc: Dan Magenheimer; Xen-devel; bderzhavets@xxxxxxxxx
> Subject: Re: Hot plug scripts not working c/s 19355 (was: Re: [PATCH]
> xen: mask XSAVE in cpuid since we don't allow guests to use it)
> Keir Fraser wrote:
> > On 13/03/2009 15:46, "Dan Magenheimer" 
> <dan.magenheimer@xxxxxxxxxx> wrote:
> >
> >   
> >> A heads-up that I just got a "(tap)...Hotplug scripts not working"
> >> completely unrelated to pvops.
> >>
> >> I updated hypervisor and tools (but notably NOT dom0 kernel) to
> >> xen-unstable c/s 19355.  Launching a domain now fails with the
> >> above error.  Rolling tools (only) back to 19187 makes the
> >> problem go away.
> >>
> >> Is there maybe a new dependency between tools and dom0 kernel?
> >>     
> >
> > You could try reverting changeset 19342, as most likely culprit.
> >   
> Is that the fixed xen-hotplug-cleanup change?  The symptoms 
> aren't quite 
> the same; with the broken cleanup, there were lockfiles left lying 
> about, so all the "block add" scripts were blocked waiting 
> for the lock 
> to be released.  In this case, everything is just sitting there; the 
> hotplug never seems to get started.
>     J

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>