This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] [XSM] Setting of ACM Policy

To: Kuniyasu Suzaki <k.suzaki@xxxxxxxxxx>
Subject: Re: [Xen-devel] [XSM] Setting of ACM Policy
From: Dilshan Jayarathna <dilshan.jayarathna@xxxxxxxxx>
Date: Fri, 22 Aug 2008 09:45:18 +1000
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Thu, 21 Aug 2008 16:47:10 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20080822.002323.189707358.k.suzaki@xxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <20080822.002323.189707358.k.suzaki@xxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (Windows/20080421)
Hi Suzaki,

It looks like a faulty build. (I could be wrong)
If you've set ACM_SECURITY ?= y in Config.mk when you building xen, you must get ACM as the supported security subsystem when you run 'xm getpolicy'.

If you just run 'xm setpolicy', you should get error but it also tells you the supported policy type
(...The only policytype that is currently supported is 'ACM'...)

You can use
xensec_ezpolicy to create a policy in xml format. Then 'xm setpolicy...' to covert xml to binary format and to activate the policy.

But if the XSM is not build properly, none of the above will work.

Hope this helps.


Kuniyasu Suzaki wrote:

Please tell me how to setup ACM of XSM.
I could build a XSM but it doesn't work well.
  # xm getpolicy
  Supported security subsystems: None

I guess it is caused by the lack of a policy file.
I referred the following manual and tried to create poly file. 

The manual tells that the following command create a policy file
  # xm setpolicy ACM mytest

However the command doesn't work well. Please tell me create a policy file. 
I tried on Xen 3.2.1. Is the step obsolete?


Xen-devel mailing list
Xen-devel mailing list
<Prev in Thread] Current Thread [Next in Thread>