This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] Not enough RAM for domain 0 allocation.

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] Not enough RAM for domain 0 allocation.
From: Luca <lucarx76@xxxxxxxxx>
Date: Tue, 12 Aug 2008 12:37:32 -0700
Delivery-date: Tue, 12 Aug 2008 12:37:57 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:received:received:message-id:date:from:to :subject:mime-version:content-type; bh=4mq4Wk7tuYfjCUoWNCyNBMvuB2fgxc6hpuDOuLyC0A0=; b=J8RYwLIihmVXW7CqBtY6pWmn1YKpaR3Ky26vp/iIAncSAETSTikEegZIJ+QC9UKYnP 722gcBOtVQZWITS7Tf6EZE6XWPLzjAD0UL8C0K6RVal7r6WKho5IixaN5YdDi2H/ahWf sakj+Pc85PDTPPVX3hBVx7ndB5Hm/1S394rBU=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:to:subject:mime-version:content-type; b=hyO8hOWlxAhrta4iA12V7Qa9icQZ5laIQAW4M1ddPSpW1Lvs1YzU8b0+FvcdMDyjnl Y1JKy6K/vw6Y1/VWy6nS/ythWCfxVf4jXr93D1yNGJugAG6zlmeP/9WtTHXDym2fXBsc yxmqiZz2hEupKruuHi43zj2j4JcflnBWIjpyA=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Hi all,
 I have been trying to use Xen with a diskless workstation.
My system has 3G of RAM. I have built a ramdisk (whose size is 450M)  and I'm trying to load everything in memory (Xen,Dom0 and the ramdisk).

In the file arch/x86/domain_build.c the function alloc_domheap_pages
is invoked page=alloc_domheap_pages(d,order,MEMF_bit(30);  // in my case order =17

This function returns a NULL pointer, which generates the error "Not enough RAM for domain 0 allocation"
It seems that if the total size of hypervisor+dom0+ramdisk is less than 256M everything works, if it is bigger than that I got that  problem.
Is there anything I have to set? I have tried playing with dom0_mem but nothing worked.
Any hint on how to proceed would really help me a lot.


Xen-devel mailing list