This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] problems compiling Xen 3.1.3 after making changes to the

To: "Ian Campbell" <Ian.Campbell@xxxxxxxxxx>
Subject: Re: [Xen-devel] problems compiling Xen 3.1.3 after making changes to the config
From: "Girish V" <girish.xen@xxxxxxxxx>
Date: Thu, 3 Apr 2008 14:35:34 -0400
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Thu, 03 Apr 2008 11:36:02 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=beta; h=domainkey-signature:received:received:message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:references; bh=SuoyKzKazJpvcJI/NvwNFlVPppL9EYFk8KGOOPfwVgE=; b=BngMVt+oywJEizS0SGieY9ij85SfzQKS5sETl1xtscJVsH5DT0WpiAVznJKtwoBgCbPcwf96TPXIYoAXfzRHWCUrAIa8rSbQ6kcsF3HN4NUhFNxiCec5cTybJXyYsIH2bsYyUkl9tjT2+VSucRJhymoZkDoOEpfAP0J4oXAbXL0=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:references; b=IrD2iSKLodqaLuwN9rlE7r1XQ9ThVvxfjH1GT42pb/4nPIBr9C9oGP3xsfTPxwGHa89+hyoHS6peTegodUmMX/DpTvH9HfL0EOFJ4z+CRI4uQoJiNsJbwbmZ1u6+0r/pkkq1BxJ8AUqpm5RSJpvxsrOcQCUiBkUi/5Yn79Euydk=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <1207216884.24799.101.camel@xxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <2122f0920804021317x491446aar170ff6554bb5deb3@xxxxxxxxxxxxxx> <1207216884.24799.101.camel@xxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Thanks Ian. I tried what you suggested and Xen compiled fine.

Now another problem has cropped up. When I try to boot up dom0, I get a kernel panic. I am compiling Xen 3.1.3 on FC5. I have made sure that all IDE modules (my disk is IDE) are compiled in and are not modules using the make menuconfig.

I am building the ramdisk using mkinitrd initrd.img

My grub.conf is

# grub.conf generated by anaconda
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,0)
#          kernel /boot/vmlinuz-version ro root=/dev/hda1
#          initrd /boot/initrd-version.img
title Fedora Core (2.6.15-1.2054_FC5)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.15-1.2054_FC5 ro root=LABEL=/ rhgb quiet
        initrd /boot/initrd-2.6.15-1.2054_FC5.img

title Xen 3.1.3 (2.6.18-xen)
        root (hd0,0)
        kernel /boot/xen.gz dom0_mem=256M noreboot com1=38400,8n1 sync_console
        module /boot/vmlinuz-2.6.18-xen ro root=LABEL=/ console=ttyS0 console=tty pnacpi=off
        module /boot/initrd-3.1.3-xen.img
        #module /boot/initrd-3.0.2-xen-readme.img
        #module /boot/initrd-3.0.2-xen-preload.img

I have shown the panic message below. (Full boot up message in file attached)


Freeing unused kernel memory: 196k freed
input: ImExPS/2 Generic Explorer Mouse as /class/input/input1
ide_disk: no version for "struct_module" found: kernel tainted.
BUG: unable to handle kernel paging request at virtual address 1eee0077
 printing eip:
003e1000 -> *pde = 00000000:1ebe0001
003e0000 -> *pme = 00000000:00000000
Oops: 0000 [#1]
Modules linked in: ext3 jbd ide_disk
CPU:    0
EIP:    0061:[<c0161739>]    Tainted: GF     VLI
EFLAGS: 00000246   ( #1)
EIP is at unmap_vmas+0x489/0x910
eax: 00000000   ebx: 1eee0067   ecx: 00000000   edx: 1eee0067
esi: 1eee0067   edi: 1eee0067   ebp: c03cca28   esp: c00d7eac
ds: 007b   es: 007b   ss: 0069
Process init (pid: 1, ti=c00d6000 task=c00d55f0 task.ti=c00d6000)
Stack: 1eee0067 00000000 d0250088 1eee0067 1eee0067 1eee0067 00000000 b7f45000
       c03dbf3c c00d7f68 1eee0067 00000000 003ff000 b7f45000 00000000 00000000
       b7f46000 c03e1010 c03e2e40 1eee0067 c1212200 00000000 00000000 c03e2e84
Call Trace:
 [<c015ab46>] __pagevec_lru_add_active+0xe6/0x130
 [<c016669b>] unmap_region+0x9b/0x120
 [<c01671ad>] do_munmap+0x14d/0x1e0
 [<c0167272>] sys_munmap+0x32/0x50
 [<c010562f>] syscall_call+0x7/0xb
Code: 00 3b b0 98 00 00 00 0f 84 5a 02 00 00 81 fe 00 e1 34 c0 0f 84 4e 02 00 00 8b 44 24 08 89 45 04 c7 45 00 40 00 00 00 8b 54 24 4c <f6> 42 10 01 0f 84 c2 01 00 00 83 6c 24 54 01 8b 44 24 4c e8 0f
EIP: [<c0161739>] unmap_vmas+0x489/0x910 SS:ESP 0069:c00d7eac
 <0>Kernel panic - not syncing: Attempted to kill init!
 (XEN) Domain 0 crashed: 'noreboot' set - not rebooting.

I tried searching for this "unable to handle kernel paging" error  on the mailing list, but I could not find any fix for it.

Any ideas why the kernel panic happens?


On Thu, Apr 3, 2008 at 6:01 AM, Ian Campbell <Ian.Campbell@xxxxxxxxxx> wrote:

On Wed, 2008-04-02 at 16:17 -0400, Girish V wrote:
> Hello,
> I am trying to compile and boot Xen 3.1.3 with linux- on a
> FC5 machine (gcc 4.1.0).
> I modified the default linux- file by doing the
> following
> 1) cd xen-3.1.3/linux-

This should be xen-3.1.3/build-linux- then the rest
of your commands should work OK.

You will need to run "make mrproper" in xen-3.1.3/linux- to
undo what you did already.

The issues is that the Xen build system uses out of tree builds (the O=
in the output below) so source is in linux- and objects are
in build-* (this saves having multiple copies of the source).

You have caused the source tree to be used as an object tree which leads
to the error you have observed.

> 2) make menuconfig (marked ide drivers to be compiled in instead of as
> modules)
> 3) cd ../
> 4) make
> Make fails with the following message
> -------------------------------------------------------------------------------------------------------
> make[3]: Entering directory
> `/root/xen-3.1.3/build-linux-'
> make -C /root/xen-3.1.3/linux-
> O=/root/xen-3.1.3/build-linux- vmlinuz
>   Using /root/xen-3.1.3/linux- as source for kernel
>   /root/xen-3.1.3/linux- is not clean, please run 'make
> mrproper'
>   in the '/root/xen-3.1.3/linux-' directory.
> make[5]: *** [prepare3] Error 1
> make[4]: *** [vmlinuz] Error 2
> make[3]: *** [vmlinuz] Error 2
> make[3]: Leaving directory
> `/root/xen-3.1.3/build-linux-'
> make[2]: *** [build] Error 2
> make[2]: Leaving directory `/root/xen-3.1.3'
> make[1]: *** [linux-2.6-xen-install] Error 2
> make[1]: Leaving directory `/root/xen-3.1.3'
> make: *** [install-kernels] Error 1
> -------------------------------------------------------------------------------------------------------
> Any help is appreciated.
> Thanks,
> Girish
> _______________________________________________
> Xen-devel mailing list
> Xen-devel@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-devel

Attachment: kernel_panic
Description: Binary data

Xen-devel mailing list
<Prev in Thread] Current Thread [Next in Thread>