This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] [PATCH] let XEN depend on PAE

To: Arnd Hannemann <hannemann@xxxxxxxxxxxxxxxxxxx>
Subject: Re: [Xen-devel] [PATCH] let XEN depend on PAE
From: Jeremy Fitzhardinge <jeremy@xxxxxxxx>
Date: Fri, 22 Feb 2008 13:13:52 -0800
Cc: Chris Wright <chrisw@xxxxxxxxxxxx>, xen-devel@xxxxxxxxxxxxxxxxxxx, Linux Kernel Mailing List <linux-kernel@xxxxxxxxxxxxxxx>
Delivery-date: Fri, 22 Feb 2008 13:17:32 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <47BF266F.5020806@xxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <47BEAB48.7050900@xxxxxxxxxxxxxxxxxxx> <47BEFA4C.6030400@xxxxxxxx> <47BEFE55.7020703@xxxxxxxxxxxxxxxxxxx> <47BF1B8F.5090701@xxxxxxxx> <47BF266F.5020806@xxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (X11/20071115)
Arnd Hannemann wrote:
Jeremy Fitzhardinge wrote:
Arnd Hannemann wrote:
This is with, but latest-git looks the same:
I also tried with 2.6.23 which crashes instantly, without any output
of the guest.
I'm not too surprised.  Non-PAE Xen is a bit of a rarity, and it only
gets tested rarely.  Chris Wright did spend some time on it a while ago,
but I don't know that its had any real attention since.  I've been
making sure non-PAE compiles, but I've been lax about testing it.
This is the first usermode exec, I guess?  The backtrace is a bit odd;
I've never seen a problem in move_page_tables before.

Yes its trying to execute the first script in initramfs, I also tried with 
and got a similar error. (move_page_tables also involved)

Does "xm dmesg" tell you what Xen is complaining about?  You may need to
compile with debug=y in Config.mk.

(XEN) mm.c:645:d44 Non-privileged (44) attempt to map I/O space 00000000

I will recompile with debug=y and post the output.
If I reduce the dom0 memory with dom0_mem=200000 I see something like
00000080 with dom0_mem=800000 I always see 00000000.

That's helpful.  Looks like the mfn is getting mushed to 0.


Xen-devel mailing list