This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Regression in serial console on ia64

To: Markus Armbruster <armbru@xxxxxxxxxx>
Subject: Re: [Xen-devel] Regression in serial console on ia64
From: Horms <horms@xxxxxxxxxxxx>
Date: Wed, 12 Sep 2007 12:47:21 +0900
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx, xen-ia64-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Tue, 11 Sep 2007 20:47:54 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <87myvt4azw.fsf@xxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <C30C386A.1561C%Keir.Fraser@xxxxxxxxxxxx> <87myvt4azw.fsf@xxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: mutt-ng/devel-r804 (Debian)
On Tue, Sep 11, 2007 at 02:55:47PM +0200, Markus Armbruster wrote:
> Keir Fraser <Keir.Fraser@xxxxxxxxxxxx> writes:
> > On 11/9/07 12:12, "Keir Fraser" <Keir.Fraser@xxxxxxxxxxxx> wrote:
> >
> >> On 11/9/07 12:06, "Horms" <horms@xxxxxxxxxxxx> wrote:
> >> 
> >>> I havnen't investigated why, but 52f308b17bae
> >>> "xencons: Remove xencons_early_setup() and do not clear use_vt_console."
> >>> seems to cause a regression on ia64.
> >>> 
> >>> The problem is that with this change applied the console
> >>> seems to stop just before the end of boot - no more output,
> >>> no input.
> >> 
> >> Is this when booting dom0? And its serial output (via Xen) that is 
> >> affected?
> >> Do you have console=xvc0 on your dom0 cmdline (and no other console= 
> >> lines)?
> >
> > My guess is that you have console=tty0 on your cmdline and this is taking
> > precedence over your serial console for init output. I've seen this kind of
> > issue before on native when trying to have both console=tty0 and
> > console=ttyS0 on the cmdline -- init output always seems to go to only one
> > or the other. I think it's supposed to be the case that the *last* console=
> > on your cmdline is the one that gets /dev/console and thus gets to swallow
> > init's output. I'm not sure what the fix is (if any) if you really want your
> > init output to go to multiple console sinks.
> Kernel messages (printk) go to all registered consoles with flag
> User space talks to /dev/console.  The kernel routes that to the
> preferred console, which is the last one on the command line, if any,
> or else the first one to register (typically the virtual terminal).


Thanks for the help.

Previously I had console=tty0 console=ttyS0, which used to work fine
but now doesn't. Though perhaps it shouldn't have worked at all.

I now have console=ttyS0 only, and everything is working fine.

I am guessing that with dual consoles, printk is going to both consoles,
but user-space only goes to the first console, as Markus suggests. And I
guess that for some reason previously user-space also went to both

I also tried with console=ttyS0 console=tty0, and both printk and
in this case user-space does not seem to go to the serial console,
perhaps tty0 always wins for some reason?

Thanks again.

  H: http://www.vergenet.net/~horms/
  W: http://www.valinux.co.jp/en/

Xen-devel mailing list