This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] ask for the xen boot when panic on mount rootfs

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] ask for the xen boot when panic on mount rootfs
From: "wang jeppeter" <jeppeter@xxxxxxxxx>
Date: Wed, 30 May 2007 22:09:45 +0800
Delivery-date: Wed, 30 May 2007 07:07:58 -0700
Dkim-signature: a=rsa-sha1; c=relaxed/relaxed; d=gmail.com; s=beta; h=domainkey-signature:received:received:message-id:date:from:to:subject:mime-version:content-type; b=fIwGNkqWuYxnIyc7gnHuMdTKZ5A0mpE4iD/2nXYb00DfCS6Ur3eClSWxYwBcy3N7mKyc/wGo+/wzFD6B+88GZzU5SLvuFzOzknn7Kqq23oCQ/hHPaZ6azM7/ZBN7rgzE6sRzeA029L7VGUiCN3x+yoLA4OSJOzNSrHDMblyV9d0=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:to:subject:mime-version:content-type; b=f48kykeRMm0ivfcw3TFEih24cQfgQXU5XOHZGD0Li65+fGf00/KZ2oAarrWQj2FY151UxqiF1xnEDhM34jZle6dDJkcmONowkNSTtQ8R/je7e+NubIfEEJZPVR7dcjpBCjBklj7fvb50fGVmzx02p3+0NvleREaebbOq2bwPXe4=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
     hello , i have a question when i boot from the xen built on 3.0.4 source code which made i stumble on mounting rootfs , i get it panic when it can not open rootfs . my disk is sata disk of WD 250G ,and i built all the source code in ubuntu feisty amd-64 platform on gcc-3.4.1 compiler . First time i doubt whether i am not compile the ext3 file system in the xen kernel (my rootfs is ext3 file system),but when i rebuilt it with assuring of the ext3 fs in the xen kernel , i met the same error,  the grub menu.lst  is like this
title xen opt 
root   (hd0,5)
kernel  /xen-2.16.gz
module  /vmlinuz-2.6.16-xen ro root=/dev/sda3 console=tty0
because my root fs is /dev/sda3 and i mount   /dev/sda6 for /boot directory 
root (hd0,5) is just copied from the right one of ubuntu original kernel.
when i switched to the ubuntu  xen package on command "apt-get install xenman ",it also failed on the same error ,can not open sda3 for rootfs.
would someone help me ,which the problem it is .
thank you very much .
Xen-devel mailing list
<Prev in Thread] Current Thread [Next in Thread>