This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] running {MS/free}-DOS under XEN

To: "Petersson, Mats" <Mats.Petersson@xxxxxxx>, xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] running {MS/free}-DOS under XEN
From: Tomas Kovacik <Tomas.Kovacik@xxxxxxxxxxxxxx>
Date: Fri, 11 May 2007 11:03:14 +0200
Delivery-date: Fri, 11 May 2007 08:56:15 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <907625E08839C4409CE5768403633E0B018E1CE8@xxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <907625E08839C4409CE5768403633E0B018E1CE8@xxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird 1.5 (Windows/20051201)
Hi Mats.
here is output from my xm info:
[root@aero xen]# xm info
host                   : aero
release                : 2.6.20-1.2316.fc5xen
version                : #1 SMP Fri Apr 27 19:36:52 EDT 2007
machine                : x86_64
nr_cpus                : 8
nr_nodes               : 1
sockets_per_node       : 2
cores_per_socket       : 2
threads_per_core       : 2
cpu_mhz                : 2992
hw_caps                : bfebfbff:20100800:00000000:00000180:0000e4bd:00000000:00000001
total_memory           : 3070
free_memory            : 272
xen_major              : 3
xen_minor              : 0
xen_extra              : .3-0-1.2316.fc5
xen_caps               : xen-3.0-x86_64 hvm-3.0-x86_32 hvm-3.0-x86_32p hvm-3.0-x86_64
xen_pagesize           : 4096
platform_params        : virt_start=0xffff800000000000
xen_changeset          : unavailable
cc_compiler            : gcc version 4.1.1 20070105 (Red Hat 4.1.1-51)
cc_compile_by          : brewbuilder
cc_compile_domain      : build.redhat.com
cc_compile_date        : Fri Apr 27 18:52:28 EDT 2007
xend_config_format     : 2

do you know how could I install newer version of XEN, as you mentioned xen-3.1-testing, in fedora core I use? i tried yum install xen but it does not give me any newer version. do you know where could i find i.e. repositories for yum(which would be more confortable) or sources or package i could use? \
as you can see, i use Intel processors, which might be the problem as you mentioned...
the thing is, i need DOS to run pharlab under it. i used qemu before. I run DOS successfully, but than when i was trying to run pharlab, it died with some other problem i cannot find even mentioned on internet, as pharlab is not usual software to use(it is kind of telecommunication switching centre running on proprietary HW up on DOS)
any idea?

Petersson, Mats wrote:

-----Original Message-----
From: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx 
[mailto:xen-devel-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of 
Tomas Kovacik
Sent: 10 May 2007 10:00
To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] running {MS/free}-DOS under XEN

Hi there.
I was looking around for a log time but I did not find any 
user who would be able to run MS-DOS or freeDOS under Xen. I 
use vmlinuz-2.6.20-1.2316.fc5xen kernel and when I try to 
boot MS-DOS 7.1 it freezes with message shown in attachement 
1. Also freeDOS freezes with message as in attachement2.
I tried to install these two systems from the same iso image 
under qemu and it went OK so it seems that XEN there is some 
issue with XEN and DOS running together.

Which version of Xen is this ("xm info" will give you version numbers),
and is it an AMD or Intel processor you're using?

I have recently (and succcessfully) run MS-DOS 6.22c on an AMD-V capable
processor with xen-unstable, changeset circa 14800. I expect this will
work on the latest xen-3.1-testing version as well. Whether it works on
older versions, I'll let you figure out. 

On Intel processors, there is a potential problemm in that these
processors don't support native real-mode in virtualized mode. This
means that the guest has to trick around with "vm86-mode", which causes
problems particularly with dos-extenders that switch from real mode to
protected mode and back again [the real problem here is maintaining the
extended segment values that may have been set during the excursion to
protected mode - if there is no segment values "expected to survive" the
transition, it should work just fine to switch between modes on Intel
processors too]. 


could somebody help me to run some version od DOS under XEN? 
thank you very much.



Xen-devel mailing list
<Prev in Thread] Current Thread [Next in Thread>