This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] [PATCH] [XEND] tweak XendDomainInfo to allow architectur

To: Hollis Blanchard <hollisb@xxxxxxxxxx>
Subject: Re: [Xen-devel] [PATCH] [XEND] tweak XendDomainInfo to allow architectures to subclass
From: Alastair Tse <atse@xxxxxxxxxxxxx>
Date: Sat, 23 Sep 2006 10:29:14 +0100
Cc: xen-devel <xen-devel@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Sat, 23 Sep 2006 02:33:06 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <1158955352.4586.18.camel@xxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <b46d3d47063ac5134384.1158780224@xxxxxxxxxxxxxxxxxxxxx> <1158955352.4586.18.camel@xxxxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx

On 22 Sep 2006, at 21:02, Hollis Blanchard wrote:

Hi, thanks for checking in the earlier patch, Alistair. Do you have any
comments on this one?

It looks like the "import arch" statement isn't needed, at least, since
there's a (stranger) import statement for it later.

Stranger because it is an absolute import rather than a relative one, which is a good thing. :)

The patch looks OK and the impact is pretty low since the impact is only contained within XendDomainInfo.py. domainTypes should probably be renamed to _domainTypes just to make it explicit it is not to be accessed outside of this module. Also, type is a built-in python function, better to rename that to something else, just in case.



Xen-devel mailing list